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ToupView help  

ToupView is designed for UCMOS, UHCCD or other USB cameras. With ToupView, one 

can browse images, preview videos, capture images, and process captured images.  

ToupView has 4 main user GUIs, they are:  

Start Frame: ToupView's initial frame.  

Browser Frame: Browser to browse images.  

Live Capture Frame: Preview video and capture images.  

Process Frame: Process the captured images.   
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1 Process Frame  

1.1 Process Frame Introduction  
The Process Frame is specially designed to process the captured image. It 

includes:   

1. Process Frame Menu.  
2. Start Frame Toolbar: See Start Frame: Start Frame Toolbar.  
3. Annotation Toolbar: See Process Frame: Annotation Toolbar.  
4. Tool Box: See Process Frame: Tool Box.  
5. Annotation Manager: See Process Frame: View->Annotation Manager.  
6. Process Frame Statusbar: See Process Frame: Process Frame Statusbar.  
7. Image Window: Window to display image.  
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1.2 File  

1.2.1 Open Image•••Ctrl+O  

Choose Open Image•••  command to open an existing image file. Open Image••• 

can also be used to preview an image in small size, or to view its statistics 

without actually opening the image itself. These capabilities can be used to 

quickly locate a particular image.  

ToupView supports and can open many image formats. These are identified in the 

Files of type list box.  

  

When open an image, ToupView places it into a new image window. It then 

becomes the active image. More than one image can be opened within ToupView 

simultaneously.  

Note: ToupView maintains, at the bottom of the File menu, a list of the last 

4 opened files. Any of these files can be accessed by simply clicking on its 
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file name. If no files are listed (beneath Exit), the Open Image••• command 

must be used to open the file.  

Also, View->Browser can be used to view images under any selected directory. 

Brief information is given in View->Browser.  

File name: From this list box, select the name of the file want to open. 

Either the type of the file name (with its entire path, if it is not in the 

current folder), or selecting Files of type to obtain a list of file names. 

Double-clicking a file name in the large list box (where both folder and file 

names are listed) will automatically open it.  

Note: If just type in the file name, be sure that the Files of type field 

correctly identify the format of the file to open. Otherwise error messages 

will pop-up when ToupView tries to open the file.  

Files of type: In this list box, select the image format of the file to open. 

If one selects All supported formats, ToupView uses the file's extension to 

identify its format. ToupView supports the following file formats:  

Window Bitmap(*.bmp,*.dib,*.rle) JPEG(*.jpg,*.jpeg,*.jpe,*.jif,*.jfif)  

Portable Network Graphics(*.png)  

Tag Image File Format(*.tif, *.tiff)  

Compuserve GIF (*.gif)  

Targa(*.tga)  

PhotoShop(*.psd)  

ICON(*.ico)  

Enhanced Window Metafile(*.emf)  

Window Metafile(*.wmf)  

JBIG(*.jbg)  

Wireless Bitmap(*.wbmp)  

ToupView File Type(*.tft)  

If the image file does not use standard format-identifying extensions, the 

file in the File name field must be typed, and then select its format from 

the Files of type list box. Otherwise, ToupView will select a format based 

on the file name extension.  

Preview: Click this button to preview image in small size. In preview mode, 

statistics about the image (i.e. image Width, Height and image location) will 

be displayed. The default state is no Preview.  

1.2.2 Open Video•••  
Choose Open Video••• command to open an existing video file.  
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1.2.3 Save   Ctrl+S  

Choose Save  command to immediately store the contents of the current 

window to its file (the file listed on the window's title bar) while leaving 

the image still active in its window. If the image is in an untitled window, 

ToupView will issue the Save As dialog.  

The Save command can be used to save the most recent changes to disk. It is 

often performed as a precautionary measure during lengthy or involved 

processes to reduce the amount of reprocessing that might be required in the 

event of a system failure or operational error. When an image is closed and 

not to save its changes is chosen, ToupView discards all changes made since 

the last Save operation.  

Note: the Save command always saves the contents of the entire window, even 

if there is an AOI (Area of Interest) defined within it.  

1.2.4 Save As•••  
Choose Save As command to store the contents of the current window to a 

specified file format. At the end of a Save As operation, the image window 

will be associated with the new file and the new format (i.e., its title bar 

will display the new file name).  

  

ToupView supported file save formats are:  
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Window Bitmap(*.bmp,*.dib,*.rle)  

JPEG(*.jpg,*.jpeg,*.jpe,*.jif,*.jfif)  

Portable Network Graphics(*.png)  

Tag Image File Format(*.tif, *.tiff)  

Compuserve GIF (*.gif)  

PCX(*.pcx)  

Targa(*.tga)  

JBIG(*.jbg)  

ToupView File Type(*.tft)  

Save in: Find the folder where the file wishes to be saved. A new folder may 

be created using the New Folder button.  

File name: Enter to be saved file name. To specify the file's location, either 

enter its entire path (disk and folder), or specify its location using the 

Save in list box.  

Save as type: In this list box, select the format in which the image wants 

to be saved. Save As is also used to convert a single image from one format 

to another. For example, if a TIFF file needs to convert to PCX format, open 

the TIFF image first, then choose the Save As command with the PCX format 

option to save it to a new file.  

The Save As command has several important uses beyond simply storing an image 

to a new file name.  

Click the Option button to select the different parameters to save the file.  

For Window Bitmap(*.bmp,*.dib,*.rle), Option will be in gray style, which 

means that no operations are needed  

For JPEG(*.jpg,*.jpeg,*.jpe,*.jif,*.jfif), Option has the following items:   
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Image quality  If one save an image in JPEG format (*.jpg), one may adjust 

image quality in the edit box. The values range from 0 to 

100.  

Default value: 75.  

Progressive  The default is unchecked.  

Optimize Huffman 
codes  

The default is unchecked.  

Smoothing  The values range between 0 and 100. Default value: 0.  

Save these 
setting as 
defaults  

When saving a file, the current settings will be saved as 
defaults for the next file save operation.  

For Portable Network Graphics(*.png), Option has the following items:  

  

Interlaced  The default is unchecked.  
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Save these setting 
as defaults  

When saving a file, the current settings will be saved 
as defaults for the next file save operation.  

For Tag Image File Format(*.tif, *.tiff), Option has the following items:   

  

Appended pages  
Determine whether the current image will be saved in 
multiple pages style or not.  

Compressions  

Specifies a method for compressing the composite image 
data.  

For saving a 32‑ bit TIFF file, one can specify that the 
file be saved with predictor compression, but have no 
option to use JPEG compression. Predictor compression 
offers improved compression by rearranging floating point 
values, and works with both LZW and ZIP compression.  

Image quality  

If choose Compressions as "JPEG", the Image quality can 
be adjusted by the slider bar. The values range between 
0 and 100. Default value: 75.  

Save these setting 
as defaults  When saving a file, the current settings will be saved as  

 defaults for the next file save operation.  

For  

Compuserve GIF (*.gif)  

PCX(*.pcx)  

Targa(*.tga)  

JBIG(*.jbg)  

ToupView File Type(*.tft)  
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There is no Option.  

Note: 1. Detailed information of the above academic terminologies can be found 

in books about image processing and image compression or on the internet.  

2. One can check Save the current directory in the registry when exit the 

application to keep his directory unchanged when he starts ToupView the next 

time. See Options->Preferences••• for more details.  

  

1.2.5 Export to Image  
When there are Annotation objects above the Background layer, this menu will 

be enabled. If this menu is chosen, the Annotation objects on the image will 

be merged together with the Background layer and the image will be polluted 

and cannot be restored again.  

After Export to Image is performed, there will only be a default layer called 

Background layer displayed in the list view on the Tool Box Layer Page, the 

Layer menu (Except the New••• submenu), the Annotation menu and the items 

about the Annotation menu on the Annotation Toolbar, will be disabled.  

1.2.6 Export to Excel  
When there are Annotation objects above the image Background layer, this menu 

will be enabled. If this command is chosen, the Annotation objects on the 

image will be exported to Microsoft Excel with the Annotation object and image 

together. The objects' parameters in the Annotation Manager will also be 

exported as a table on the same frame with the image.  
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1.2.7 Paste as New File•••  
Choose the Paste as New File••• command to place the contents of the clipboard 

image into a new image window, which becomes the active image.  

Before execute the Paste as New File command, valid image data must be copied 

to the clipboard first (see the Copy command). If there is no image data on 

the clipboard, the Paste as New File••• command will be disabled.  

The new image type will be the same as that of the original image. ToupView 

will accept image data from other applications via the clipboard as long as 

it is in Windows Bitmap (DIB) format.  

1.2.8 Print Setup•••  
Choose this command to access the setup panel for the printer that have 

selected. ToupView will present the standard setup panel for the particular 

printer (this is the same panel one would receive if one were setting up the 

printer from the Windows Control Panel). Change printer's setup to satisfy 

the requirements, click OK button to return.  

1.2.9 Print Preview•••  Ctrl+Shift+P  
Choose the Print Preview command to see the real-time effect of the printer 

without actually printing it out.  
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1.2.10 Print•••  Ctrl+P  

Choose the Print  command to print one or more copies of the current image 

to the selected output device. The ToupView Print command lets one take full 

advantage of the printer's capabilities. If the printer has built-in half-

toning or color dithering capabilities, use them or instruct ToupView to 

perform these processes before sending the image to the device.  

The Print command also has facilities that let one adjust the size and position 

of the image on the printed page.  

1.2.11 Recent Files  
ToupView maintains a recent 4 (default) most recently opened document files 

under the Print menu. Choose one of these menus immediately reopens that file.  

1. The maximum number of Recent Files can be changed by choose the Options-

>Preferences••• Misc tab. Here, clicking the 4 (default) edit box will allow 

to input the number of items that want. The values range from 0 to 8.  

2. One can check Clear the Recent Files when exit the application to clear 

the Recent Files.  

  

1.2.12 Exit  
Choose the Exit command will close all of the active images and remove their 

windows from the screen. After all of the images are closed, ToupView will 

end itself.  
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Note: 1. If an image has been modified before attempting to Exit it, ToupView 
will issue a warning to ask if user want to save the image first.   

  

1.3 Acquire  

1.3.1 Live Capture 
Introduction  

DirectShow's main design goal is to simplify the task of creating multimedia 

applications on the Windows® platform by isolating applications from the 

complexities of data transports, hardware differences, and synchronization 

issues. It is designed to address each of these challenges.  

To achieve the throughput necessary for streaming video and audio, DirectShow 

uses DirectDraw and DirectSound to render data efficiently to the system's 

sound and graphics cards. Synchronization is achieved by encapsulating the 

multimedia data in time-stamped media samples. To handle the variety of 

sources, formats, and hardware devices, DirectShow uses a modular 

architecture in which operating system components called filters can be mixed 

and matched to provide support for many different scenarios.  

DirectShow includes filters that support codes written for the Audio Compression 

Manager (ACM) and Video Compression Manager (VCM) interfaces.  

DirectShow enables applications to play files and streams from various 

sources, including local files and remote files on a network. DirectShow has 

native compressors and decompressors for some file formats, and there are 

many third-party hardware and software decoders that are compatible with 

DirectShow. In addition, DirectShow supports legacy VFW codes based on the 

Video Compression Manager (VCM) and Audio Compression Manager (ACM) 

interfaces. Playback makes full use of the DirectDraw hardware acceleration 

and DirectSound capabilities when the hardware supports it.  

When should I use this technique?  

The DirectShow technique is widely used in low-resolution video devices, such 

as those with resolutions smaller than 640X480. However, for UCMOS or UHCCD 

camera, any resolution can be displayed. For high resolution, Twain Acquire 

is suggested.  
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If the hardware and drivers support the DirectShow technique, this technique 

can be used to capture an image. To start Live Capture video, choose one of 

the following methods:  

Start methods   

1. Live Capture toolbar method   

Click the  button on the Start Frame Toolbar   

2. Live Capture menu method   

Choose Acquire->Live Capture->XXX device menu, XXX is the installed device 
name   

3. Live Capture Start Page method  
Click the device name on the Start Page under Live Capture item to start the 

Live Capture window.  

  

1.3.2 Software Power  

This command is used to choose the Software Power  of the 

microscope to connect the video or image resolutions and the microscope 

objective in the Live Capture window or the image window.  

The images captured under different Software Power will have different 

resolutions, so correct Software Power should be chosen before perform any 

video measurement or capture the image.  

There are two methods to choose the Software Power. They are:  

1. Menu method: Acquire->Software Power   
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If the microscope's 4X, 10X, 40X Software Power is defined with Live Capture 

Toolbar: Define Software Power. There should be the following submenus under 

the Software Power.  

  

If nothing is set, only Pixel submenu is listed  

2. Live Capture toolbar method   

Click the Zoom dropdown arrow  on the Live Capture Toolbar to choose 

the Software Power.  

  

Note: Before image capture, the correct Software Power should be selected 

first. (For Twain:Acquire, one should check highest resolution on the Setup-

>Video Stream Format••• dialog)  

About the Software Power definition, see more in Live Capture Toolbar: Define 

Software Power.  

1.3.3 Manage Software Power•••  Ctrl+M  
The Manage Software Power•••'s main functions are:  

Modify the Software Power Order  

The Manage Software Power••• menu will display a Software Power dialog as:  
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Select the Software Power item, click Delete••• button to delete the selected 

item.  

Select the Software Power item, click the Up or Down button to change the 

Software Power list order.  

Click Clear All••• to delete all of the Software Power items.  

Export and Import the Software Power  

If one wishes to reuse the Software Power, a backup is needed first.  

Click Export••• to backup the Software Power in a safe media. The file 

extension is *.magn.  

After the new installation is finished, the Software Power can be import by 

choose Acquire->Manage Software Power••• and click Import••• to load the 

previously saved *.magn file.  

If everything is ok, press OK to end the management.  

1.3.4 Video Marker•••  
Choose Video Marker••• to overlay Video Marker on the Live Capture window. 

The Video Marker type may be Cross, Rectangle, Circle, Cross+Rectangle, or 

Cross+Circle. The Video Marker is as follows:  
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Choose Type “Cross+Retangle”, fill in the Cross Width and Cross Height, 

Rectangle Width and Rectangle Height, x Offset and y Offset, click Color••• 

to define the Video Marker color, click OK to end the Video Marker dialog. 

There should be a Cross+ Rectangle marker on the Live Capture window as shown 

below.  

  

Note: Check  button the Live Capture Toolbar and using keyboard arrow key 

to move the Video Marker. See Live Capture Frame: Live Capture Toolbar->Arrow 

key to move marker or watermark for details.  
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1.3.5 Video Overlay Text•••  Ctrl+D  

Choose Acquire->Video Overlay Text••• to overlay Software Power, Scale and 

Date, and Clarity Factor on the Live Capture window.  

This command will invoke Text Overlay dialog box as below. The Position, Font 

size, Font Weight of the Software Power, Scale and Date, and Clarity Factor 

can be defined together. Their Colors can be defined separately.  

  

Click OK, the Software Power, Scale & Date plus Clarity Factor are now 

overlaid on the Live Capture window. The Clarity Factor can tell if the sample 

is in good focus. The larger the Clarity Factor, the clearer the sample 

focused.  
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Note: To enable the Scale bar, the Software Power must be defined and 

selected. The Unit can be any unit except Pixel. Choose Options-

>Annotation•••, click Unit, Length to check the desired Unit. The Unit can 

also be chosen on Live Capture Statusbar. See Live Capture Frame: Live Capture 

Statusbar for details.  

1.3.6 Video Watermark•••  Ctrl+W  
Fig.1 shows the Live Capture window. It is actually a micro ruler. The dark 

lines can be extracted as Video Watermark and overlaid on the Live Capture 

window.  

The steps are:  

1. Click  to capture the image as shown in Fig.1.  
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Fig.1 Micro ruler captured from the 
Live  
Capture Window  

Fig.2 Micro ruler after binarized  

2. Choose Process->Binary••• to binarize the image as in Fig.2.  

3. Choose the Image->Adjust->Invert command to invert the image. Choose Image-
>Color Quantize••• to convert 24 bits as in Fig.3. Choose File->Save As to 
save the image in 24 bit BMP format.  

    

Fig.3 Inverted 24 bits image  Fig.4 Video Watermark setup dialog  

4. Choose Acquire->Video Watermark•••, and a dialog called Video Watermark is  

popped up as in Fig.4. Click the  button to locate the image saved in step  

3. Set the Threshold in color, input the Transparent(%) value, and either 

check or uncheck Use the watermark color. If checked, choose the Watermark 

Color. If everything is ok, click OK button. The final Video Watermark is 

shown Fig.5.  
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Fig.5 Live Capture Window with Video Watermark overlaid   

5. Check  and use the keyboard arrow keys to move or rotate the 
Video  

Watermark. Please refer to Live Capture Toolbar: Arrow key to move marker or 

watermark and Live Capture Toolbar: Arrow key to rotate watermark for details.  

  

Fig.6 Video Watermark moved and rotated  
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1.3.7 Auto Maximum Size•••  Ctrl+U  
This is for Live Capture window only. Choose this menu will show an Auto 

Maximum Size dialog box as below:  

  

In the Size of Preview group, 3 items can be checked.  

1. Use Maximum Size Automatically: ToupView will enumerate the possible 

maximum size the camera support and set the Live Capture window to the maximum 

size for preview.  

2. Use Maximum Size Automatically when lake of "Capacity of Still Image 

Capture": If the camera does not support the Still Image Capture pin, ToupView 

will set the Live Capture window to the maximum size for preview. To check 

if the camera supports Still Image Capture or not, choose Setup->View 

Property•••and see if Still Image Capture’s value is Y or N.  

3. Don't Use Maximum Size Automatically: If one wish to preview the video 

in a smaller size at high speed, the video can be set to a specific size (see 

Setup->Video Stream Format•••). Check this item will load the specified size 

after ToupView start again at next time.  

In the Size of Still Capture group, there are 2 items:  

1. Use Maximum Size Automatically: If this item is checked, ToupView will 

enumerate the possible Still Image Capture maximum size the camera supports 

and set the Still Image Capture to maximum one to capture the image 

(suggested).  

2. Don't Use Maximum Size Automatically: If one wish to capture in smaller 

sizes, set the Still Image Capture to specific size (Setup->Still Capture 

Options•••). Check this item will load the specified size after ToupView 

start again at next time.  
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1.3.8 Capture with Marker and Watermark  Ctrl+F  
If this submenu is checked, the captured image will be merged with the Video 

Marker or Video Watermark.  

1.3.9 Twain: Select Device•••  
Introduction  

Twain is a cross-platform interface for acquiring images captured by certain 

scanners, digital cameras, or frame grabbers. The manufacturer of the Twain 

Device must provide a Source Manager and Twain Data Source to work with 

ToupView.  

Select the active device for Twain: Acquire••• from all devices available in 

the device list box which are enumerated by the application.  

One must install the Twain Device and its driver and restart computer before 

one can use it to import images into ToupView. See the documentations provided 

by the device manufacturer for the installation instructions.  

Menu method   

Before begin to start Twain: Acquire at the first time with ToupView, choose  

Acquire->Twain:Select Device  first, then select the device. One does not 

need to repeat this step for subsequent use of the Twain Acquire.  

  

Toolbar Method   

Click  to invoke the Select Source dialog and select the listed camera 

name, click Select to end the command.  

Note: If more than one Twain Devices are installed, choose the Twain:Select 

Device command to select the right one.  

1.3.10 Twain:Acquire•••  
Introduction  
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There are basically two techniques used to capture the video images from video 

devices such as a PC camera, digital camera, and scanner. They are the  

Twain:Acquire  technique and the DirectShow technique (previously called 

VFW).  

The most obvious characteristics of the Twain technique is that it displays 

the live video in smaller resolution but captures the image in high 

resolution. ToupTek’s USCMOS and UHCCD series cameras support all of these 

two image capture techniques.  

Steps for Twain Acquire  

Here we illustrate how to capture the image using a UCMOS00350KPA (350K pixels, 

USB2.0) camera as an example.  

1. Install the driver UCMOS00350KPA from the disc.  

2. Install the software ToupView from the disc.  

3. Plug the cameras UCMOS00350KPA (USB2.0) into the computer.  

4. Double click the icon ToupView to start it.  

5. Choose the Acquire->Twain:Select Device••• command or click  button on 
the  

Live Capture Toolbar. Select the device UCMOS00350KPA from the Select Source 

dialog.  

7. Choose the Acquire->Twain: Acquire••• menu as shown in the figure or click 

 on the Live Capture Toolbar.  

8. There should be a dialog box like the following:  
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9. In this dialog, Video Resolution can be selected (dropdown list). The Video 
Source Property••• can be set by click the Setting••• button. Click the 

Capture button to capture the image.  

  

1.4 Edit  

1.4.1 Undo  
Most of the operations in ToupView can be undone. Alternatively, one can 

restore all or part of an image to its last saved version. The basic Undo 

process is:  

1. Choose Open Image••• to open an image.  

2. Choose Image->Adjust->Auto Level, then Edit->Undo will be enabled.  
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3. Choose Edit->Undo. This will cancel the Image->Auto Level operation and 
return the image to its initial opened state.   

  

If return to the Edit menu, one will find that Edit->Undo now becomes Edit-

>Redo. One can select one of these two operations to see the Undo and Redo 

changes:  

1. Choose Edit->Redo. The image will return to Image->Auto Level status and 
Edit->Undo will be enabled again.  

2. Choose Image->Auto Contrast, then Edit->Redo will become Edit->Undo.  

Note: ToupView supports only one step Undo and Redo operations.  

1.4.2 Forward  
This command will move the current displayed image to the next step listed in 

the Tool Box Operations Page (If it is not in the last step).  

Forward Demo  

Now we continue the Edit->Backward demo. Since it is in Index 1, Edit->Backward 

is disabled and Edit->Forward is enabled. The status is shown in Fig.1.  

1. Choose Edit->Forward and the image and the index will advance forward 

to Fig.2. Now Edit->Backward is enabled.   

2. Choose Edit->Forward again to go to Index 3 as shown in Figure 3. Now 

Edit->Backward is still enabled, but because it is in the last step, Edit-

>Forward is disabled.  

See Edit->Backward for further information.  
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1.4.3 Backward  
This command will move the current displayed image to the previous index listed 

in the Tool Box Operations Page (If it is not in the "Open" status).  

Backward Demo  

1. Choose Open Image••• to open an image.  

2. Choose Image->Adjust->Color.  

3. Choose Image->Adjust->Invert. The final image is shown in Index 3. Since 
it is in the last step, not in Index 1, the Edit->Backward will be enabled.  

4. Choose Edit->Backward, and the image and the index will return to Index 2 
as shown in Index 2. Since it is in Index 2, Edit->Forward will be enabled.  

5. Choose Edit->Backward again, and the image and the index will return to 
Index 1 as shown in Index.3. Since it is in the 3rd step, Edit->Forward 

will still be enabled, but Edit->Backward will now be disabled.  

See Edit->Forward for further information.  
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1.4.4 Cut  Ctrl+X  

Choose Cut  command to copy the selected Annotation objects to the 

clipboard and delete the selected objects on the image. Any data already 

exist on the clipboard will be replaced.  

The data copied to the clipboard can be pasted into the active window or into 

another opened image window on the extra layer using the Paste command (when 

the current layer is not in the Background layer, this command can be 

activated, otherwise, it is disabled).  

Note: This command does not support Background layer Cut operation.  

1.4.5 Copy  Ctrl+C  

Choose Copy  command to Copy the selected objects (on Annotation layer) 

or an image's selected area on the Background layer to the clipboard. 1. Copy 

the selected area on the Background layer to the clipboard.  
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a) Select the source area to Copy using the  button on the Annotation 

Toolbar. The Copy menu and the  button on the Start Frame Toolbar will 

be enabled.  

b) Choose Edit->Copy or click  to copy the selected image area to the 
clipboard.   

2. Copy object(s) on the Annotation layer to the clipboard.  

a) For the layer operation, see the Tool Box Layer Page.  

b) For the annotation operation, see the Tool Box Annotation Page.  

c) After the Annotation operating has been done, check the Object Selection 

button . The cursor will change into .  

d) Move the mouse until the cursor becomes , this means the cursor is 

now right on the Object. Click it and the Object will be highlighted and 

selected.  

e) Optional: Continue to move the mouse until the cursor becomes , this 

means the cursor is now right on the object again. Click it with SHIFT+left 

mouse button and the second object will be selected and highlighted.  

  

f) Optional: (1) With the cursor over the image, click down the left mouse 
button. (2)Drag the mouse to draw a rectangle on the image. A dotted 

rectangle will appear around the selected area. (3) Release the mouse and 
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all of the Annotation objects within the dotted rectangle will be 

highlighted and selected.  

g) After the Annotation objects are selected, the menus Edit->Copy and the 

 button on the Start Frame Toolbar will be enabled.  

h) Choose Edit > Copy to Copy the object(s) to the clipboard. Then the Edit-

>Paste menu and  button will be enabled. One can then Paste the objects 

above the Background layer or onto the other image that has an Annotation 

layer. If one switches to the Background layer, the Paste command will be 

disabled, but if one returns to the Annotation layer, the Paste command 

will be enabled again.  

Note: If there is no Annotation object selected, the Copy command will be 

disabled. Copy will not delete the Annotation objects on the image. Any data 

already existing on the clipboard will be replaced with the new data.  

The copied object(s) can be pasted into the active window or into another 

opened window using the Paste command as long as the current window is not on 

the  

Background layer (the command is disabled). See Tool Box Layer Page for detail.  

1.4.6 Paste  Ctrl+V  

Choose Paste  command to put objects from the clipboard onto the active 
image's  

Annotation Layer. One can also choose the Paste command to transfer a layer's  

Annotation objects from one image window's Annotation Layer to another image's 

Annotation Layer.  

Before executing the Paste command, valid Annotation object must have been 

copied into the clipboard (see the Copy command). If there is no Annotation 

object data in the clipboard, the Paste command will be disabled. When the 

current layer is not the Background layer, this command can be activated as 

long as the clipboard has the Annotation object, otherwise, it is disabled. 

This means that the command does not support the image area Paste operation.  

1.4.7 Image Select  

This command turns the cursor into an Image Select  tool. One can mark 

areas to Cut, Copy, or relocate.  
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To select an area, drag the mouse cursor across the image with the left button 

held down until the area is selected. Release the button and the area will 

be marked. Handles will appear on the area that will allow alter the selection 

after it is marked. Zooming in or out on the image will delete the selected 

area.  

  

The Image Select button (or Edit->Image Select menu) will be enabled when the 

Background is active.  

  

Check this button or choose this menu will keep down its button on the 

Annotation Toolbar or check its menu. After the area is selected, the Edit-

>Copy button (or menu) will be enabled and then the selected area can copy 

to the clipboard for further application.  

When the Background Layer’s Current check box is not checked, this button will 

be disabled.  

1.4.8 Select All  Ctrl+A  
1. Select All on the Background layer  

To Select All pixels on the Background layer within the canvas when the 

Background layer is active, Choose Edit->Select All (shortcut: Ctrl+A).  

2. Select All objects on the extra layer  

When the Background layer is not active, choose the Edit->Select All command.  

Select All will select all of the objects on the object layer.  
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1.4.9 Select None  
Deselect any selected area on the image or the layer objects.   

1. When the current layer is the Background layer and an area is selected, 

the Select None option will be enabled. Choose Edit->Select None will delete 

the dotted rectangle representing the selected area.  

2. When the current layer is not the Background layer and the Annotation 

objects is selected, the Select None menu will be enabled. Choose Edit-

>Select None will deselect all of the selected Annotation objects.  

  

1.5 View  

1.5.1 Browser   Ctrl+B  
Choose Browser from the View menu (shortcut: Ctrl+B) or click the Browser 

toolbar button  to browse images on the hard disk. When clicks Browser, 

ToupView will display a Browser window that looks like Windows Explorer. The 

child window on the left part of the Browser window is used to browse images 

on the hard disk. Images in the current directory are displayed in Large 

Icons or Small Icons mode on the right side of the Browser window.  

The Browser can be used to perform tasks such as creating new folders, 

renaming, moving, and deleting files. Individual file information and import 

data from digital cameras can also be displayed. Double clicking the left 

mouse button on the icon will open the image as an active image in full size. 

See Browser Frame for more details.  

1.5.2 Tool Box   Ctrl+T  
The Tool Box is a property sheet that has 3 tabbed pages, which are:  

Tool Box Operations Page shows the operations performed on the active image 

and one can easily jump to the other operation step. One can also delete the 

selected steps.  

Tool Box Layer Page allows one to annotate the opened image on a layer above 

the Background layer without polluting the original image information. Think 

of layers as sheets stacked one on top of the other. When there is no image 

on a layer, one can see through to the layers below.  
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Tool Box Annotation Page shows the selected layer object. One can also modify 

the object's Appearance and Coordinates here. It also shows the Calculation 

results according to the object's Coordinates.  

For details, please See: Process Frame: Tool Box.  

1.5.3 Annotation Manager  
When choose the Annotation Manager command, the Annotation Manager shows the 

object's possible features, such as Name, Center Point, Radius, Area, 

Perimeter, Angle, Start Point, and End Point, drawn on the extra layer. One 

can resize the columns for the best fit, or hide the uninteresting item.  

Click the right mouse button on the Annotation Manager••• and the following 

context menus or submenus will be popped up on the Annotation Manager•••:  

File Import•••.  

Choose this item to load an outline or Annotation file (*.annotation) and 

display it on the current image.  

File Save•••  

Choose this item to save the Annotation objects on the current image to an 

annotation file (*.annotation).  
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Export->To Clipboard->All Layers  

Export all layers' Annotation objects to the clipboard.  

Export->To Clipboard->Current Layer  

Only export current layer's Annotation objects to the clipboard.  

Export->To Html File  

Export the Annotation objects to the *.html file in tabbed format.  

Export->To Excel•••   

Export the Annotation objects to the excel file.  

Auto Highlight  

When this menu is checked, clicking the row in the Annotation Manager will 

Highlight the corresponding Annotation object on the image layer. Clicking 

the object on the image will Highlight the corresponding row in the Annotation 

Manager.  

Settings•••  
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1. Changing the Annotation Manage item order. Select one item, and click the 
Up or Down button to move the selected item forward or backward.   

2. Check the item will show/hide the item in the Annotation Manage.   

3. Click Default will return to the ToupView's default settings.   

  

1.5.4 Rulers and Grid  
Ruler and Grid menu has 3 submenus, they are:  

1.5.4.1 Show/Hide Rulers  
Choose this menu will show/hide the horizontal and vertical rulers on the 

image top and right area  

1.5.4.2 Grids  

No Grids  There are no grids overlaid on the image.  
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Manual Grids  

Set the grids manually.  

This command will display two small triangles on the active 

window’s upper left corner.  

  

Move the mouse to the small triangle will show horizontal or 
vertical drag icons. Drag this small triangle horizontally or 
vertically to the desired position and release it will, a line 
will overlay there as Manual Grids. Continue the drag operation  

 

will draw the other grid on the image.  

  

Auto Grids  Overlay the grids on the image automatically.  

Remove All  

Grids  

Remove all of the manually or auto set grids.  

1.5.4.3 Settings•••  
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Choose this menu will show the Ruler and Grid Setting dialog. In this dialog, 

one can select Ruler Color, Cursor Color, Grid Style, Line Style, and Line 

Color.  

Check Save these settings as defaults will save the current settings for the 

next time when ToupView launches. The figure shown above displays the Ruler 

and Grid set.  

1.5.5 Cursor Settings•••  
This command will set the mouse cursor for the Layer Annotation operation.  

Select the Horizontal cursor in:  

None (window default), Single (single line), Double(1 Pixel), Double(3 Pixels), 

Double(5 Pixels), Double(7 Pixels), and Double(9 Pixels) formats.   

Single means single line. Double means two parallel lines. 1 Pixel means the 

line space between the two lines is 1 pixel in space. The other sizes also 

have this ratio.  
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Select the Vertical cursor in:  

None (window default), Single (single line), Double(1 Pixel), Double(3 Pixels), 

Double(5 Pixels), Double(7 Pixels), and Double(9 Pixels) formats.  

Single means single line. Double means two parallel lines. 1 Pixel means the 

line space between the two lines is 1 pixel in space. The other sizes also 

have this ratio.  

Select the cursor shape: Cross, Point, and Null.  

In the following figure, cursor with a Single horizontal line, Double vertical 

lines with 9 Pixels, and the Cursor as a Cross is defined   

Note: The Cursor will be active only when there is an extra Layer (excluding 

the Background layer) above the image.  

  

1.5.6 Best Fit  NumPad*  
Choose Best Fit to automatically resize the image to fit in the window.  

1.5.7 Actual Size  NumPad/  
Choose Actual Size to set the active image to its actual size (e.g. 100%). 

This option will not be enabled if the image is currently viewed at 100%. At 

any other zoom ratio, Actual Size will be enabled.  
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1.5.8 Zoom Tool  
1. Choose Zoom Tool to Zoom In or Zoom Out using the left and right mouse 

buttons.  

Choose this menu will automatically check  on the Annotation Toolbar. The  

cursor will become . One can click the left mouse button on the image to 

zoom in the image and click the right mouse button to zoom out the image.  

Choose this menu again will uncheck this menu and the  button will return 

to its unchecked state.  

2. Zoom In by click the  button on the Annotation Toolbar.  

3. Zoom Out by click the  button on the Annotation Toolbar.  

4. One can also choose Zoom button’s dropdown arrow to select the image display 
ratio on the Process Frame: Annotation Toolbar.  

  

1.5.9 Track  
If the image's actual size is larger than the image window, check this command 

to move the image to display the specified area. Its function is similar to 

the scroll bars.  

Check this menu will change the cursor to  and the button on the Annotation 

Toolbar will be checked.  

Then press down the mouse button to drag the region of interest on the image 

to any location in the image window.  
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1.6 Image  

1.6.1 Mode  

1.6.1.1 Color Quantize  

The Color Quantize command is widely used to change the image bit. ToupView 

supports the mutual changes among 1, 4, 8, and 24 bit images.  

When the dialog is opened, the default checked color bit is the image's color 

bit. Check the desired bit and click OK to end the command. The image will 

converted to the selected color bits.   

  

1.6.1.2 Gray Scale  

Choose the Gray Scale command to convert a color image (true color image or 

index color image) to a gray scale image. If the original image is 24 bit, 

the new image is 8 bit. Otherwise the bit of the image will not modified.  

1.6.2 Adjust  

1.6.2.1 Curve•••  
Choose the Curve••• dialog to adjust the entire tonal range of an image. But 

instead of making adjustments using only three variables (highlight, shadow, 

midtone), one can adjust any point on the curve along a 0-255 scale while 

keeping up to 15 other values constant. One can also use Curve to make precise 

adjustments to individual color channels on an image.  
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The horizontal axis of the graph represents the original intensity values of 

the pixels (Input levels).  

The vertical axis represents the new color values (Output levels). In the 

default diagonal line, all of the pixels have identical Input and Output 

values.  

Curve: Drag the Curve until the image looks satisfactory.  

Pencil: Check the pencil button at the bottom of the dialog, and drag it to 

draw a new arbitrary Curve.  

Channel: To adjust the color balance of the image, check the channel(R, G or 

B) from the Channel button. Check the white button to select RGB channels at 

the same time, which is located on the left of the R (Red), G (Green) and B 

(Blue) buttons.  

1.6.2.2 Auto Level  
The Auto Level command moves the level's sliders automatically to set 

highlight and shadow. It defines the lightest and darkest pixels in each 

color channel as white and black and then redistributes the pixels' color 

values proportionately. Since Auto Level adjusts each color channel 

individually, it may remove or introduce color casts. The Auto Level command 

moves the level's sliders automatically to set highlight and shadow. It 

defines the lightest and darkest pixels in each color channel as white and 

black and then redistributes the pixels' color values proportionately. Since 

Auto Level adjusts each color channel individually, it may remove or introduce 

color casts.  

By default, this feature clips the white and black pixels by 0.5%--that is, 

it ignores 0.5% of the lightest pixels and 0.5% of the darkest pixels when 

identifying the lightest and darkest pixels on the image. Choose the Options-
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>Auto Correction•••.menu to modify this default setting. This ensures that 

white and black values are representative without being determined by extreme 

pixel values.  

The Auto Correction••• dialog is shown below:  

  

Auto Level gives good results when an image with an average distribution of 

pixel values needs a simple contrast adjustment or when an image has an 

overall color cast. However, adjusting the Curves manually is more precise.  

See Auto Contrast for another auto adjust command.  

1.6.2.3 Auto Contrast  
The Auto Contrast command automatically adjusts the overall contrast and 

mixture of colors in an RGB image. Since it does not adjust channels 

individually, Auto Contrast does not introduce or remove color casts. It maps 

the lightest and darkest pixels in the image to white and black, which makes 

highlights appear lighter and shadows appear darker.  

When identifying the lightest and darkest pixels on an image, Auto Contrast 

clips the white and black pixels by 0.5%--that is, it ignores the first 0.5% 

of either extreme.  

Choose the Options->Auto Correction•••.menu to modify this default setting. 

This ensures that white and black values are representative without being 

determined by extreme pixel values. The Auto Correction••• dialog is shown 

below:  

  

Auto Contrast can improve the appearance of many photographic or continuous-

tone images. It does not improve flat-color images.  
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See Auto Level for another auto operation.  

1.6.2.4 Histogram Equalization  
Histogram Equalization is a kind of histogram process. The histogram can 

reflect the statistical information for the R, G, and B of the pixels of the 

original image. The algorithm calculates each separately, equalizes the R, 

G, and B of the points linearly, and reassigns them  

1.6.2.5 Brightness/Contrast•••  
The Brightness/Contrast••• command offers simple adjustments to the tonal 

range of an image. This command makes the same adjustment to every pixel in 

the image. The Brightness/Contrast command does not work with individual 

channels and is not recommended for high-end output because it can result in 

the loss of details about the image.  

  

Preview: Check this button to display real-time effects when drags the slider 

bar.  

Brightness: Dragging the slider bar to the left decreases the level and 

dragging it to the right increases the level. The numbers on the right of the 

slider bar displays the Brightness value. Values can range from -100 to +100.  

Contrast: Dragging the slider bar to the left decreases the level and dragging 

it to the right increases the level. The numbers on the right of the slider 

bar displays the Contrast value. Values can range from -100 to +100.  

1.6.2.6 Color•••  

Choose the Color••• command to modify the overall mixture of the colors in an 

image.  
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There are four color modules:  

RGB  ToupView uses the RGB model. It assigns an intensity value to each 

pixel ranging from 0 (black) to 255 (white) for each of the RGB 

components in a color image.  

For example, a bright red color might have an R value of 246, a G value 

of 20, and a B value of 50. When the values of all three components 

are equal, the result is a shade of neutral gray. When the value of 

all components is 255, the result is pure white; when the value is 0, 

pure black.  

RGB images use three channels to reproduce up to 16.7 million colors 

on-screen. In addition to being the default mode for new ToupView 

images, the RGB mode is used by computer monitors to display colors. 

This means that when working in color modes other than RGB, such as 

CMYK, ToupView uses RGB mode for display on-screen.  

Although RGB is a standard color mode, the exact range of colors 
represented can vary, depending on the application or display device.  

CMYK  The CMYK mode is based on the light-absorbing quality of ink printed 

on papers. As white light strikes translucent inks, certain visible 

wavelengths are absorbed while others are reflected back to the eyes.  

In theory, pure cyan (C), magenta (M), and yellow (Y) pigments should 
combine to absorb all light and produce black. For this reason these 
colors are called subtractive colors. Because all printing inks contain 
some  
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 impurities, these three inks actually produce a muddy brown and must 

be combined with black (K) ink to produce a true black. (K is used 

instead of B to avoid confusion with blue.) Combining these inks to 

reproduce color is called four-color process printing.  

The subtractive (CMY) and additive (RGB) colors are complementary 
colors. Each pair of subtractive colors creates an additive color, and 
vice versa.  

HSI  Based on the human perception of color, the HSI model describes three 

fundamental characteristics of colors:  

Hue is the color reflected from or transmitted through an object. It 

is measured as a location on the standard color wheel, expressed as a 

degree between 0° and 360°. In common use, Hue is identified by the 

name of the color such as red, orange, or green.  

Saturation, sometimes called chroma, is the strength or purity of the 

color. Saturation represents the amount of gray in proportion to the 

hue, measured as a percentage from 0% (gray) to 100% (fully saturated). 

On the standard color wheel, Saturation increases from the center to 

the edge.  

Intensity is the relative lightness or darkness of the color, usually 
measured as a percentage from 0% (black) to 100% (white).  

HLS  The HLS model is very similar to the HLS color model. The main 
difference between them is the calculation used to produce the 
brightness value. In the HLS model, a pixel's brightness (L) is derived 
from its three (R, G and B) color values. In the HLS model, a pixel's 
brightness (L) is determined by the minimum and maximum values of its 
three color values.  

Preview: Check this button to display the real-time effect when the slider 

bar's position is changed.  

The values beside the slider bar show the color changes in various color 
channels.  

For RGB channel values, they can range from -100 to +100.  

For CMYK channel values, they can range from -100 to +100.  

For HSI channel values, the H value can range from -180 to 180, the S value 

can range from -275 to 275, and the I value can range from -442 to 442.  

For HLS channel values, the H value can range from -180 to 180, the L value 

can range from -100 to 100, and the S value can range from -100 to 100.  
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1.6.2.7 HMS···  
Choose HMS command to adjust the HL (Highlight), M (Midtone), and S(Shadow) 

parts of the image. Each part's value ranges from -100 to 100. This command 

is only available for 24 bits true color image.  

  

Preview: Check this button to display the real-time effect when one changes 

the slider bar's position.  

1.6.2.8 Gamma•••  
Gamma measures the brightness of midtone values produced by a device (often a 

monitor). A higher gamma value yields an overall darker image.   

  

Preview: Check this button to display the real-time effects when one changes 

the slider bar’s position.  

Gamma: Dragging the slider bar to the left decreases the level, while moving 

it to the right increases the level. Values can range from 0 to 3.0.  

1.6.2.9 Filter Color•••  
Choose the Filter Color command to filter a special color channel from a 

color image. Check either Red, or Green, or Blue color to filter. For every 

pixel, if check Red color to filter, only information about the red channel 

will be discarded, and Green and Blue information will remain.  
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See Extract Color••• for another color operation.  

1.6.2.10 Extract Color•••  
Choose the Extract Color••• command to extract a special color channel from a 

color image. Choose either Red or Green, or Blue color to extract.   

For every pixel, if check Red color to extract, only information about the red 

channel will be kept, and Green and Blue information will be discarded.  

  

See Filter Color••• for another color operation.  

1.6.2.11 Invert  
Choose Invert command to reverse the pixel values of the active image without 

going through the lookup table  

1.6.3 Rotate  
Choose the Rotate command to rotate the entire image. One has the following 

options:  

1.6.3.1 90(CW)  
Rotate the image clockwise by a quarter-turn.  

1.6.3.2 180(CW)  
Rotate the image clockwise by 180 degrees.  

1.6.3.3 270(CW)  
Rotate the image clockwise by 270 degrees.  



  

   

  

  

60  

1.6.3.4 Arbitrary•••  
Rotate the image by a specified angle. If choose this option, enter an angle 

between 0 and 360 degrees in the angle text box, and check CW or CCW to rotate 

clockwise or counterclockwise.  

For the Arbitrary••• operation, it will open a dialog like below:  

  

Degree: The degree that the image to be rotated.  

CW: Rotates the image clockwise.  

CCW: Rotates the image counterclockwise.  

Quality: One can select one of the three methods for the image rotation among 

Nearest Neighbor, Bilinear, and Bicubic. The default is Bilinear.  

1.6.3.5 Flip Horizontal  
Reverses the image in the application area so that the top right corner of 

the original image is now the top left, and the top left corner of the 

original image is now the top right corner.  

1.6.3.6 Flip Vertical  
Reverses the image in the application area so that the top right corner of 

the original image is now the bottom right corner, and the top left corner 

of the original image is now the bottom left corner.  

1.6.4 Crop  
Choose the Crop command to remove the portions of an image that does not want 

so that the focus is on the part of the image that is left. This document 

instructs users on how to Crop an image in ToupView.  

Crop Demo   

1. Choose Open Image••• to open the image to Crop.  

2. Click  on the Annotation Toolbar, the cursor will change to a small 
cross.  
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3. Move the cursor over the image to the desired location, click the mouse 
button and hold it down.  

  

4. Drag the mouse over the part of the image to be kept, a dotted rectangle 
appears around the selection.  

5. Optional: To move the rectangle   

a) Move the mouse over the selected area and when it becomes a move cursor, 
click and hold the left mouse button.  

b) Drag the selected area to the desired position.  

6. Optional: To change the size of the rectangle  

a) Put the mouse cursor on one of the handles that appear on the edges of 
the selected area.  

b) Click and hold the mouse button.  

c) Drag the box to the desired size.  

Note: Each of the handles that appear on the edges of the box sizes the box 

differently.  

7. To Crop the image, select Image->Crop.  

1.6.5 Image Scale•••  
Choose the Image Scale command to change the image to a specified size. This 

process actually changes spatial resolution by adding (replicating) or 

removing (decimating) pixels to achieve the specified dimensions.  
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Width and Height: When choose the Image Scale command; the dialog displays 

the dimensions of the original image in pixels. The Width and the Height can 

be set on the new image by adding or removing pixels. If Constrain Proportions 

is checked, the Width and Height will stay proportionate to each other. If 

Constrain Proportions is unchecked, the Width and the Height can set 

independently, but this will distort the image.  

Reset: Reset the image Width and Height to the original ones.  

Constrain Proportions: To maintain the current proportions of pixel Width and 

Height, check Constrain Proportions. This option automatically updates the 

Width as the Height is modified, and vice versa. Otherwise, uncheck the 

Constrain Proportions button.  

Scale method: There are 3 options for the Scale method. They are: Nearest 

Neighbor, Bilinear, and Bicubic. The default is Bilinear.  

1.6.6 Histogram•••  
A Histogram illustrates how pixels in an image are distributed by graphing 

the number of pixels at each color intensity level. The Histogram shows 

whether the image contains enough detail in the shadows (shown in the left 

part of the Histogram), Midtones (shown in the middle), and highlights (shown 

in the right part) in order to make a good correction.  

The Histogram also gives a quick picture of the tonal range of the image, or 

the image key type. A low-key image has detail concentrated in the shadows, 

a high-key image has detail concentrated in the highlights, and an average-

key image has detail concentrated in the Midtones. An image with a full tonal 

range has a number of pixels in all areas. Identifying the tonal range helps 

determine the appropriate tonal corrections.  

Choose Image->Histogram••• to open the Histogram dialog as shown below.  
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Depending on the image’s color mode, choose R, G and B, or Luminosity to view 

a composite Histogram of all the channels.  

If the image is RGB true color, choose Luminosity to display a Histogram 

representing the luminance or intensity values of the composite channel.  

If the image is RGB true color, choose R, G and B to display a composite 

Histogram of the individual color channels in color.  

Do one of the following:  

To view information about a specific pixel value, place the mouse pointer in 

the Histogram.  

To view information about a range of values, click down the left mouse button 

and drag it in the Histogram to highlight the range.  

The dialog displays the following statistical information below the Histogram:  

Pixels: Represents the total number of pixels used to calculate the Histogram. 

Level: Displays the intensity level of the area underneath the pointer.  

Count: Shows the total number of pixels corresponding to the intensity level 

underneath the pointer.  
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Percentile: Displays the cumulative number of pixels at or below the level 

underneath the pointer. This value is expressed as a percentage of all of the 

pixels in the image, from 0% at the far left to 100% at the far right.  

1.6.7 Resolution•••  
Choose this command to set the image Resolution to calibrate the spatial 

scale. By default, ToupView expresses spatial measurements in terms of pixels. 

This Resolution command is used to change the terms in which ToupView reports 

such measurements. This command should be run first if in order o measure 

objects in terms of units other than pixels.  

  

X: Horizontal PPM (Pixels per meter) of current Resolution.  

Y: Vertical PPM (Pixels per meter) of current Resolution.  

Note: The resolution in the Y direction need not to be filled. ToupView will 

always let it equal to the X direction.  

After the new Resolution is set, all of the measurements will be calculated 

according to the new Resolution. (See more in the Annotation Manager•••).   
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1.7 Process  

1.7.1 Filter•••  Shift+F  
Choose Filter command to apply one of ToupView's numerous Filters to the 

active image. If one is not familiar with the process and effects of 

filtering, some discussions about spatial filtering should be reviewed. 

ToupView provides an extensive set of convolution and no convolution 

(morphological) Filters. One can also create custom filter kernels and apply 

them with the Filter commands.  

Choose the Filter command will open the Filter dialog. Each group of Filters 

has its own property sheet or tab, where the Filter type and size can be 

selected. Filtered results are almost always written to the active image. 

Edit->Undo command can be used to remove Filter operations that have been 

applied.  

Choose the Filter command displays the Filter property dialog.  

1.7.1.1 Image Enhance  
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Low Pass   Check this filter to soften an image by eliminating high-
frequency information (this has the effect of blurring sharp 
edges). The Low Pass filter replaces the center pixel with the 
mean value in its neighborhood. The Low Pass filter can also 
be used to remove noise.  

High Pass  Check this filter to enhance high-frequency information. The 
High Pass filter replaces the center pixel with a convolved 
value that significantly increases its contrast from its 
neighbors. The High Pass filter leaves only elements of high 
contrast.  

Gauss  Check this filter to soften an image by eliminating high-
frequency  

 information using a Gauss function. This has the effect of 
blurring sharp edges. The operation of the Gauss filter is 
similar to the Low Pass filter, but it degrades the image less 
than the Low Pass filter.  

High Gauss  Check this filter to enhance fine details. This operation is 
similar to the unsharp masking technique (see the Sharpen 
filter), but it introduces less noise into the image. It uses 
a Gaussian curve type of kernel. Available in 7x7 and 9x9 kernel 
sizes.  

Equalization  This filter is used to enhance the contrast based on the 
histogram of the local neighborhood (See Option below).  

Sharpness  Check this filter to enhance fine details, or refocus an image 
that is blurred. The sharpen filter sharpens the image using 
the unsharp masking technique.  

Median  Check this filter to remove impulse noise from an image. The 
Median filter replaces the center pixel with the Median value 
in its neighborhood. It will also blur the image.  
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Rank  Check this filter to remove impulse noise from an image. The 
pixels in the kernel are ranked by order of intensity, and the 
pixel in that range at the rank percentage is chosen for 
comparison. For example, in a 5x5 kernel, there are 25 pixels. 
A rank percentage of 95% would choose the second-brightest 
pixel for comparison. If the difference between the selected 
pixel and the center pixel is greater than the threshold value, 
the Rank filter replaces the value of the center pixel with the 
value of the selected pixel.  

Option:   

1. If one of the Enhancement filters is checked, the following options will 
be  

 

3 x 3  Check 3 x 3 kernel will produce a more subtle filtering effect.  

5 x 5  Check 5 x 5 kernel will produce a moderate filtering effect.  

7 x 7  Check 7 x 7 kernel will produces a more extreme filtering effect.  

Passes  Set the filter applied times on the image. When a filter is applied 
multiple times, its effect is amplified by each pass. An image that 
has been softened by one pass of the Low Pass filter will be 
softened further by a second pass.  

Strength  Enter an applied value from 1-10 that reflects how much of the 

filtering effect on the image.  

A value of 10 specifies the full strength (100%) of the filtered 
result applied to each pixel. Values less than 10 cut the full weight 
of the  

 filter.  

A value of 1 indicates that only 10% of the difference between the 
filtered pixel value and the original pixel value should be applied, 
a value of 2 indicates that 20% of the difference should be applied, 
and so forth.  

displayed:  



  

   

  

  

68  

Rank  This value specifies which pixel in the sorted array will be used 

to replace the center pixel. Pixels in the array will be sorted in 

ascending order. The pixels are indexed from 0 to Kernel Size x 

Kernel Size-1. In the pixel index 0 corresponds to the lowest pixel 

value.  

The Rank will be specified in terms of a percentage of the indexes 
(Kernel Size x Kernel Size-1). A 50% Rank means the middle of the 
array. 0% rank means the lowest index (lowest gray value), and 100% 
rank means the highest index (highest gray value).  

2.If Equalization filters is checked, the options will relate to the histogram 
equalization. Local Histogram Equalization modifies the contrast of an image 
based on the pixel values in a small window surrounding each pixel.  

Window  Image pixels statistics (min, max, histogram, mean, standard 
deviation, etc.) will be calculated on a small Window of the 
image. These measurements are then used to derive the local 
contrast for that area of the image. In short, an area of Window 
x Window around each pixel is all that is considered when 
modifying the intensities in the image. Larger Window produces 
smoother results, while small Window track small details more 
closely.  

Best Fit  Choose Best Fit command to optimize the values for the particular 
image. The results are achieved by stretching the local histogram 
to maximize the contrast between the brightest and darkest pixels 
in the local window region.  

Linear  This option distributes the histogram linearly across the 
intensity scale. This function produces a high contrast image 
with the highest possible dynamic range.  

Logarithmic  This option concentrates the histogram at the low end of the 
scale. This function produces a high contrast image with little 
dynamic image. It will tend to darken the image overall. It is 
useful for increasing the contrast in a very light image.  

Exponential  This option concentrates the histogram at the high end of the 
scale. This function produces a high contrast image with little 
dynamic image. It will tend to lighten the image overall. It is 
useful for increasing the contrast in a very dark image.  
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1.7.1.2 Edge Enhance  

  

Sobel   Check this filter to enhance just the principal edges in an 
image. The Sobel applies a mathematical formula to a 3x3 
neighborhood to locate and highlight its edges.  

Roberts  Check this filter to enhance fine edges in an image. The Roberts 
filter is not a convolution filter. It applies a mathematical 
formula upon a 4 x 4 neighborhood to produce its effect. The 
upper left pixel in the neighborhood is the one that is replaced.  

Sculpt  Check this filter to apply a sculpted effect on the image.  

Horizontal  Check this filter to detect and emphasize horizontal edges.  

Vertical  Check this filter to detect and emphasize vertical edges.  

Options:  

1. If one of the Edge filters have been checked, the options will relate to 
kernel size and filtering strength. The following options will be displayed:  

3 x 3  Check 3x3 kernel to produce a more subtle filtering effect.  

5 x 5  Check 5x5 kernel to produce a moderate filtering effect.  

7 x 7  Check 7x7 kernel to produce a more extreme filtering effect.  
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Passes   Enter the number of times that the filter will be applied to the 
image. When a filter is applied multiple times, its effect is 
amplified by each pass. An image that has been softened by one 
pass of the Image Enhancement Filter, will be softened further by 
a second pass.   

Strength   Enter a value from 1-10 that reflects how much of the filtering 
effect to apply to the image. A value of 10 specifies that the 
full strength (100%) of the filtered result will be applied to 
each pixel. Values less than 10 cut the full weight of the filter 
- a value of 1 indicates  

 that only 10% of the difference between the filtered pixel value 
and the original pixel value should be applied, a value of 2 
indicates that 20% of the difference should be applied, and so 
forth.  

2. If Sobel or Roberts is checked, no options are available.  

1.7.1.3 Morphological  

  
Erode  Check this morphological filter if one wants to modify the size 

of objects in the image. The Erode filter erodes the edges of 
bright objects and enlarges the edges of dark ones.  

Dilate   Check this morphological filter if one wants to modify the size 
of objects in the image. The Dilation filter dilates bright 
objects and erodes dark ones.   
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Open   Check this morphological filter if one wants to modify the shape 
of objects in the image. Assuming the image contains bright 
objects on a dark field, the Open filter will smooth object 
contours, separate narrowly connected objects, and remove small 
dark holes.   

Close   Check this morphological filter if one wants to modify the shape 
of the objects in the image. Assuming the image contains bright 
objects on a dark field; the Close filter will fill gaps and 
enlarge protrusions to connect objects that are close together.   

Tophat  Check this filter to detect and emphasize points, or grains, that 
are brighter than the background. There are 3 kernel sizes for 
this processing. Click the radio button to change the kernel size 
to the value that most closely matches the size of the grains to 
detect.  

Well  Check this filter to detect and emphasize points, or grains, that 
are darker than the background. There are 3 kernel sizes for this  

 processing. Click the radio button to change the kernel size to 
the value that most closely matches the size of the grains to 
detect.  

Gradient  Check this filter to enhance edges in an image.  

Watershed  Check this filter to separate objects that are touching. The 

Watershed filter erodes objects until they disappear, then dilates 

them again, but will not allow them to touch. The Watershed filter 

will not operate upon True Color images. If one wants to separate 

objects in a True Color image, he must first convert it to Gray 

Scale (see Process Frame:  

Image->Gray Scale).  

Thinning  Check this filter to reduce an image to its skeleton. When choose 
this filter, one must set the threshold that determines whether 
a pixel is part of the subject, or part of the background (see 
Options below). The Thinning filter will not operate upon True 
Color images. If one wants to thin a True Color image, he must 
first convert it to Gray Scale.   
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Distance  The distance filter is used to show the distances of pixels within 
blobs to the outer boundaries of those blobs. After applying the 
distance filter, the background will be black (i.e. pixels with 
value 0). Only the area within the blobs will have non-zero values 
(will be white). The values of each pixel within the blob will be 
a count of the shortest distance from that pixel to the edge of 
the blob. Thus, all pixels along the blob's border will have a 
value of 1 (since they are one pixel away from the edge of the 
blob); pixels that are a distance of 2 from the border will have 
the value 2, and so on. This creates a distance map of the image. 
The Distance filter will not operate upon True Color images. If 
one wants to use the Distance filter with a True Color image, he 
must first convert it to Gray Scale.  

Options:  

1. If Erode, Dilate, Open, or Close filters is checked, the options will 
relate to the kernel size and shape. The following options will be presented:  

2 x 2 Square  Check to use the 2x2 square kernel configurations.  

3 x 1 Row   Check to use the 3x1 row kernel configuration.   

1 x 3 Column   Check to use the 1x3 column kernel configuration.   

3 x 3 Cross   Check to use the 3x3 cross kernel configuration.   

5 x 5 Circle   Check to use the 5x5 circular kernel configurations.  

7 x 7 Circle   Check to use the 7x7 circular kernel configurations. This is 
a two-pass filter, accomplished using a 5 x 5 circle followed 
by a 3x3 cross.   

11 x 11 Circle   Check to use the 11 x 11 circular kernel configurations. 
This is a three-pass filter, accomplished using a 5 x 5 
circle followed by another 5 x 5 circle, followed by a 3 x 
3 cross.  

Passes  Set the number of times iterate the filter.  

Note: The circular kernels are especially effective on round objects (cells, 

grains and so on) because their circular configuration preserves the circular 

shape of the objects better than square configurations.  

2. If the Tophat, Well, or Gradient filter is selected, the options will 
relate to kernel size and shape. The following options will be presented:  
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3 x 3  Check to use the 3x3 square kernel configurations.  

5 x 5  Check to use the 5x5 square kernel configurations.  

7 x 7  Check to use the 7x7 square kernel configurations.  

3. If Watershed, Thinning, or Distance filter is checked, the options will 
relate to the threshold. The following option will be presented:  

Threshold  Enter a percentage value from 1-100 that specifies the intensity 
value to binarize the image. For example, a Threshold of 50% on 
a Gray Scale image would set all values ≤127 to 0 (black) and all 
values ≥128 to the maximum value for that image class (white).  

1.7.1.4 Kernel  

The Kernel page allows edit the kernel files for the morphological and 

convolution filters.  

  

Note: The HiPass, LowPass, Laplacian and Unsharp kernel files are used by the 

HiPass, LowPass, Laplacian, and Sharpen options listed in the Image Enhancement 

Filters tab dialog window (i.e. there is no difference between selecting one 

of these kernel files and selecting its Option button in the Filter window -

- the two methods ultimately do the same thing). Because these kernel files 

are essential to the operation of these filtering options, they must not be 

deleted or renamed.  
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Filter type  
Check to modify the kernel for a selected Filter type, either 
Convolution or Morphological filters.  

Edit•••   
Check to modify the selected filter kernel using the Edit Kernel 
dialog.   

  Name•••  This list box contains the name of the selected kernel 
file. If one wants to save the modified kernel file 
to the same file, leave it as it is. If one wants to 
save the file to a new location, enter the new 
filename here.  

Kernel  

Size  

Click the spin buttons or enter the number to change 
the size of the kernel. Either direction may take 
into account one to nine pixels. As one modifies the 
Kernel Size, the shape of the kernel representation 
changes accordingly. In the center of the dialog, 
there are white boxes containing coefficients that 
will be multiplied with each pixel that will be taken 
into account by the filter kernel. One can change any 
coefficient by clicking on it and adjust it as 
desired.  

Fill  Click this button to fill every element of the kernel 
with a particular value. The Fill kernel dialog 
appears. One may enter a value between 0 and 10. Using 
the Fill button is useful for setting all coefficients 
to the same value. One may then change the 
coefficients that require a different value.  

Offset.  The pixel whose value is being changed is usually the 
center-most pixel. One may, however, designate any 
pixel. ToupView signals the pixel to be changed by 
putting a box around it. Choose X and Y Offset spin 
buttons to apply  
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New•••  

Click to create a new filter kernel. The Edit Kernel dialog will 
appear. The functions of the dialog are the same way as the 
dialog for Edit••• described above), with the exception that the 
file name for the new kernel file must be provided.  

Delete  Click to delete the selected filter kernel file.  

Options  
The choices in this group box will vary depending upon the kind 
of selected filter.  

1.7.2 Range•••  Shift+R  
The Range command allows set the intensity levels of the image to increase 

the contrast and enhance the display in low-light situations. Choose the 

Range command opens the Range dialog.  

  

Two vertical markers show the upper and lower limits of the intensity levels. 

These markers can be moved with mouse through the drag and drop process. For 

a color image, the histogram will reflect the red, green, and blue values 

with corresponding colors lines.  

Two edit controls indicate the values of the intensity levels. Choose spin 
buttons to increase or decrease these values. All values between 0 and the 
lower limit will be black and all values between the upper limit and the 
upper end of the scale will be white.  

Reset   
The Reset button allows Reset the black and white levels to the high 
and low ends of the dynamic Range.  

Best Fit  

The Best Fit button automatically sets the intensity levels to the 
Best Fit. Best Fit instructs ToupView to optimize the brightness 
and contrast values for the particular image.  

Invert   The Invert button reverses the color of the image.  
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Update  
Update will refresh the display Range with the most current image 
information.  

1.7.3 Segmentation•••  Shift+S  
Segmentation is a process through which certain colors (or gray levels) in 

an image can be visually identified when they are isolated from the image as 

a whole. Areas identified by Segmentation (classes) can either be removed 

from or kept in the image, while discarding the remainder of the image. 

Therefore, this process can be used for separating items or objects of 

interest from the "background noise" that normally occurs in most acquired 

images.  

The process of identifying colors is the key to the operation of Segmentation. 

Due to the vast possibilities of differences in the images, and the color 

composition of the object(s) to be identified, ToupView provides Histogram 

based models for identifying the segmented area.  

  

Choose the Segmentation command on a True Color image, select either Red(R), 

Green(G), or Blue(B) channel to do the operation.  

1.7.4 Binary•••   Shift+B  
Binary is a kind of gray level process. If the gray of the pixel is greater 

than the given threshold, the pixel's color will be changed into white. 

Otherwise, the pixel's color will be changed into black. Although the process 

may lose some information, it is an important step of other processes.  

The curve on the Binary dialog shows the gray distribution of the image.  

The line in the dialog indicates the threshold value. Drag the line to change 

the threshold, or change the number in the top left corner of the dialog to 

change it.  
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Click the "Best Fit" button to apply the auto threshold process to the image.  

It uses an automatic threshold to make the image Binary.  

  

1.7.5 Emboss•••  Shift+E  
Emboss is a kind of artistic process. The process can make the image look 

like an empaistic image. The Preview button allows previewing the image before 

creating it. The process supplies 3 kinds of convolutions including Gradient, 

Different, and Prewitt.  

  

There are 8 directions in every kind of convolution. Users can get different 

effects with different convolution methods or directions.  

1.7.6 Pseudo Color•••  
Note: Image must be in Gray Scale. Choose Pseudo Color command to "colorize" 

the active monochromatic image. This is used to highlight certain features 

in a gray scale image such as display all densities above a certain point in 

red, or, the imaging device recorded thermal information, all temperatures 

below a certain point can be revealed in blue color.  
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When Pseudo Color a monochromatic image, a special palette need to be build 

with which the monochromatic image is displayed. Pseudo Coloring an image 

does not modify the pixels' values in image bitmap (it does not convert image 

to true color or palette,). It simply associates a Pseudo Color palette with 

the image that interprets the gray-level values in the image as color.   

Pseudo Colored images are very similar in structure to palette class images, 

but they differ in a couple of important ways. First, the pixels' values in 

a Pseudo Colored image actually represent continuous-tone intensity 

information, whereas a palette image's pixels carry no intensity 

significance. Secondly, a palette image includes a palette table that is 

actually part of the image file.   

The colors used to map the gray values can be selected. The buttons at each 

end of the color strip will bring up the color dialogues separately, which 

allows select the start and end colors of the range.  

1.7.7 Surface Plot•••  
The Surface Plot (or 3-D Plot) tool creates a 3-D representation of the 

intensity of an image. When choose the Surface Plot command, keep in mind 

that X=height Y=width, and Z=gray.  

In the viewpoint window, the elevation and rotation of the image can be 

adjusted by dragging the mouse on the image.  

Position Solid: The left edit control indicates the relative position of the 

entire image in the viewpoint window, whose default value is 0.5. The right 

edit control indicates the relative height of the display of the Z scale, 

whose default value is 1.  

Reset: Set the Position Solid's two edit controls to their default values.  

Image Background Color: Choose this command to display a color dialog where 

one can adjust the background color of the viewpoint window.  

Capture: Capture the active image in the viewpoint window as a new image.  
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Color Table: Select the colors to map the gray values found in the surface 

plot. The button at each end of the color table brings up the color dialog, 

which allows select the start and end colors of the range. (Please refer to 

Pseudo Color for more information)  

  

1.7.8 Line Profile•••  
Choose Line Profile••• command to illustrate how pixels along a selected line 

are distributed by graphing the number of pixels at each color intensity 

level. Before choose this command, select the Tool Box Annotation Page first 

to make or set the active layer and draw the line object above the image.  

  
In a Line Profile, the X-axis represents the spatial scale, and the Y-axis 

represents the intensity values which range from 0 to 255.  

Background: Open the windows color dialog to set the background color of the 

histogram window.  

Title: Use this command to set a title on the image's Line Profile.  

Capture: Capture the image in the Line Profile window as a new untitled image.  
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Copy: Copy the Line Profile window's content onto the clipboard.  

Save as•••: Save the Line Profile image in bmp format.  

1.7.9 Diffuse•••  Shift+D  
Diffuse is a kind of artistic process. It can diffuse the image. Users can 

adjust the parameter in the dialog to control the degree of the diffusion.  

  

Preview: Check it to display the real-time effect when drag the slider bar.  

1.7.10 Granulate•••  Shift+G  
Granulate is a process that can make the image fuzzy. One can adjust the 

parameter in the dialog to control the degree of the fuzziness.  

  

1.7.11 Mosaic•••  
Mosaic is a process that can combine the images opened into a new image. This 

will open the following dialog:  

ImgList  

Available Images: Images opened with Toupview.  

Add>>: Add the opened images to the Selected Images list view  

Add All>> Add all the opened images to the Selected Images list view Remove: 

Select the images and remove them from the Selected Images list view.  

Clear: Remove all the images from the Selected Images list view.  
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Property Page  

Title: The title wanted  

Footer: The footer wanted  

Arrangement: The Mosaic Images distribution on the page  

PageSize: The page size for the Mosaic Images  

  

If everything is set, click OK to end the Mosaic Images operations and a new 

image window will be displayed and the final results should be   
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1.7.12 Fusion•••  
Similar to the dynamic multi-focus image fusion with the live video stream, 

Static Fusion is a very useful tool to generate a clear image by combining a 

sequence of previously captured multi-focus images. Choose Process->Fusion••• 

menu, the following dialog will open (assume 01.jpg 02.jpg … 15.jpg are 

already opened in ToupView):  
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Click on the image file name in the Open list view will select the image, and 

then the Add>> button is enabled (Click on the selected images will deselect 

them). Click Add>> button, the selected images will be added into the Selected 

list view, which will be fused later.   

Click Add all button will add all images in the Open list view into the 

Selected list view.   

If images in the Selected list view is selected, the Delete button will be 

enabled. Click the Delete button, the selected images in the Selected list 

view will be removed.   

Click on the Clear button will remove all the images in the Selected list 

view, including the unselected ones. NOTE: Images used to fuse must be the 

same size, or there will be a prompt when adding different sizes of images 

as below:  

  

The prompt dialog indicates which image is not the same size with the others.  

When the desired images are all selected, the Static Fusion process can start. 

Click on the Fuse button will start the Static Fusion process, and the mouse 

cursor becomes an hourglass. When the fusion process finishes, the fused 

image will be generated in a new image window as below:  
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1.8 Layer  

1.8.1 New•••  Ctrl+N  
Create a New layer. When creating a New layer, the following item can be 

checked or set:  

1. Input a layer Name.  

2. Check or uncheck to show or hide the Label and Size.  

3. Set the Color for both the layer object's Label and Size.  
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Click OK button, the Tool Box Layer Page will look like below:  

  

A new item called New Demo has been added. This new Layer is checked as Current 

and Visible.  

Note: After the New layer is made, buttons on the Annotation Toolbar are 

enabled and all of the Annotation menu items are also enabled.  

1.8.2 Remove•••  
Remove a layer by selecting the layer name. The Current active layer cannot 

be removed.  

Remove••• steps  

1. Choose Layer->New••• to make Layer Demo1, Choose Annotation->Rectangle to 
draw a Rectangle objects in red color.  

2. Choose Layer->New••• to make Layer Demo2, Choose Annotation->Ellipse to 
draw an Ellipse objects in black. The results are shown in Fig 1.  

3. Check the Layer Demo1 on the Tool Box Layer Page to set it as Current.   

4. Choose Layer->Remove•••. Select Layer Demo2 and click OK. See Fig 2.  
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5. The final result is shown in Step 3. One can see that the Ellipse objects 
on Layer Demo2 have been removed and the Rectangle objects on Layer Demo1 

are still there. The item of Layer Demo2 on the Tool Box Layer Page has 

also been removed.  

  

1.8.3 Current•••  
Select the Current layer as an active layer.  

Current••• steps  

1. Choose Layer->New••• to make the Layer Demo1. Choose Annotation->Rectangle 
to draw a Rectangle objects in blue.  

2. Choose Layer->New••• to make the Layer Demo2. Choose Annotation>Ellipse to 
draw an Ellipse objects in red. Uncheck the Visible button of Layer Demo1. 

The Rectangle objects will be hidden. The results are shown in Fig.1.  

3. Choose Layer->Current•••. Select the Layer Demo1 and click Ok. See Fig.2.  
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4. The final result is shown in Fig.3. The Rectangle objects on Layer Demo1 
are automatically visible and the Current Layer Demo1 item on Tool Box 

Layer Page is checked.  

  

1.8.4 Show/Hide•••  
Show or Hide the layer. The Current layer must be shown and cannot be hidden.  

Show/Hide••• steps  
1. Choose Layer->New••• to make Layer Demo1, Choose Annotation->Angle to 

draw 1 Angle objects in red color.  

2. Choose Layer->New••• to make Layer Demo2, Choose Annotation->Line-

>Vertical Line to draw a Line objects in green color. The results are shown 

in Fig. 1.  
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3. Uncheck Visible on the Tool Box Operations Page’s Layer Demo1 row or 

choose Layer->Hide/Show•••.The Layer status is listed. Uncheck the Visible 

item in Layer Demo1 and end the dialog.  

4. The final result is shown in Fig 2. One can see that the Angle objects 

on Layer Demo1 are hidden. The Current button of Layer Demo1 item on the Tool 

Box  

Layer Page is still unchecked  

1.8.5 Property•••  
This Properties command will show/hide the object Label and object Size, change 

Label Color. The Layer->Property••• is shown below  
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Note: The Layer Property only controls the named layer, for example Layer 

Demo1's Label, Size and Color. The Label's show/hide property is actually 

controlled by the Options->Annotation•••->Object->XXX as shown below.  

  

1. If the Label is checked here, then uncheck RoundRect Label on the above 

Layer dialog will make the RoundRect Label invisible.  

2. If the Label is unchecked here, then the Label will always be invisible, 

regardless of whether the RoundRect Label on the above Layer dialog is checked 

or unchecked.  

3. Check the Label on the Annotation dialog first, and then check it on 

the Layer dialog to make the Label visible.  

1.8.6 Export  

1.8.6.1 Export->To Clipboard->All Layers  
Export all layers' Annotation objects to the clipboard.  

1.8.6.2 Export->To Clipboard->Current Layer  
Only export current layer's Annotation objects to the clipboard.  

1.8.6.3 Export->To Html File  
Export the Annotation objects to the *.html file in tabbed format.  

1.8.6.4 Export->To Excel•••   
Export the Annotation objects to the excel file.   
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1.9 Annotation  

1.9.1 Object Select  

This Object Select menu or toolbar button  will be enabled only when a new 

Layer above the Background layer is created.  

After Annotation is done on the specific layer, choose this menu to select the 

interested objects.  

1. The object can be selected by clicking on it.  

2. Select a group of objects by including them in a rectangular area or by 
press down the Shift key and clicking the object with mouse until all the 

desired objects are selected.   

To check or modify the parameters of the selected object, choose View->Tool 

Box, and click the Tool Box Annotation Page.  

Note: The Appearance, Coordinates and Calculation on Tool Box Annotation Page 

will be enabled only when a single object is selected.  

1.9.2 Angle  
Draw Angle on image in layer format   

After a new layer above the Background layer is created with Layer->New••• 

menu, the Angle item on the Annotation menu and its button  on the 

Annotation Toolbar will be enabled.   
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Steps:  

1. Move the mouse on the image to point 1, mark it by click the mouse button.  
2. Move the mouse to point 2, mark it by click the left mouse button.  
3. Move the mouse to point 3, mark the final point by click the left mouse 

button.  

A label A1@50.26deg will be shown near point 2.  

Changing the Angle Property   

If the Angle object is selected, the Annotation->Property••• menu and the  

Property  button on the Annotation Toolbar will be enabled. Use either one 

to invoke the Angle dialog. Here its Appearance, and the three marked point 

Positions can also be precisely adjusted.  

  

Change the Label Property   
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1. Click on the Current layer item (for example angle) with right mouse button 
on the Tool Box Annotation Page will invoke a context menu.  

2. Choose Property••• will show the Layer dialog.  
3. Here, one can change Layer Name, to determine whether to show or hide Label 

and Size items, to modify Label, Size‘s Color by just click the mouse 

button on Color button.  

1.9.3 Point  

The Annotation->Point menu and its button  on the Annotation Toolbar will 

be enabled only after a new layer above the Background layer is created with  

Layer->New••• command.  

Draw point on the image in layer format   

  

Move mouse to the point; click the left mouse to mark it. It will show the 

point Label P1 and its position x and y on the image.  

1.9.4 Line  

The Annotation-> Line menu and its button  on the Annotation Toolbar 

will be enabled only after a new layer above the Background layer is created 

with  Layer->New••• command. In the Layer dialog, the object's Label and Size 

can be checked to hide or show them, the Label’s Color can also be set at 

here.  
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Draw Line on the image in layer format   

1. Choose Annotation->Point command  

2. Move mouse to the 1st point, click the left mouse to mark it.  

3. Move mouse to the 2nd point, click the left mouse to mark it again, a line 
with L1 and its length will be shown.  

  

The other Annotation->Line’s submenu can be chosen for Annotation:  

Any Line  Draw Any Line between the two points on the specified layer.  

Horizontal Line  Draw a Horizontal Line between the two points on the 
specified layer.  

Vertical Line  Draw a Vertical Line between the two points on the specified 
layer.  
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1.9.5 Parallel  

The Annotation-> Parallel menu and its button  on the Annotation Toolbar 

will be enabled only after a new layer above the Background layer is created 

with  Layer->New••• command. In the Layer dialog, the object's Label and Size 

can be checked to hide or show them, the Label’s Color can also be set at 

here.  

  

Draw two Parallel lines on the image in layer format   

  

1. Choose Annotation->Parallel.  
2. Move mouse and click to mark the 1st point.  
3. Move mouse and click to mark the 2nd point.  
4. Move mouse and click to mark the 3rd point.  
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5. Move mouse again, one will find the 4th point is always restricted to 
parallel to the line of point 1 and point 2. Click to mark the 4th point. 

Two parallel lines will be labeled and numbered.  

6. Choose Tool Box Annotation Page to modify the parallel line Appearance, 
Coordinates.  

1.9.6 Vertical  

The Annotation->Vertical menu and its button  on the Annotation Toolbar 

will be enabled only after a new layer above the Background layer is created 

with  Layer->New••• command. In the Layer dialog, the object's Label and Size 

can be checked to hide or show them, the Label’s Color can also be set at 

here.  

  

Choose Annotation->Vertical->Four Points or Three Points menu or click  

‘s dropdown arrow and choose Four Points or Three Points item. Draw two Vertical 

lines on the image in layer format   
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1. Choose Annotation->Vertical->Four Points.  
2. Move mouse and click its left button to mark the 1st point.  
3. Move mouse and click its left button to mark the 2nd point.  
4. Move mouse and click its left button to mark the 3rd point.  
5. Move mouse again, one will find the 4th point is always restricted to 

perpendicular to the line of point 1 and point 2. Click to mark the 4th 

point.  

Two vertical lines will be labeled and numbered.  

6. Choose Annotation->Vertical->Three Points to draw vertical line.  
7. Choose Edit->Tool Box and click Tool Box Annotation Page to check or modify 

the object’s Appearance and Coordinates.  

1.9.7 Rectangle  

The Annotation->Rectangle menu and its button  on the Annotation Toolbar 

will be enabled only after a new layer above the Background layer is created 

with  Layer->New••• command. In the Layer dialog, the object's Label and Size 

can be checked to hide or show them, the Label’s Color can also be set at 

here.  

  

Draw Rectangle on the image in layer format   

1. Move mouse to the 1st point; click its left mouse button to mark it.  

2. Move mouse to the 2ed point; click its left mouse button to mark.  

1.9.8 RoundRect  

The Annotation->RoundRect menu and its button  on the Annotation Toolbar 

will be enabled only after a new layer above the Background layer is created 
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with  Layer->New••• command. In the Layer dialog, the object's Label and Size 

can be checked to hide or show them, the Label’s Color can also be set at 

here.  

  

Draw a Round Rectangle on the image in layer format   

  

1. Draw Arc object to determine the round size. Its size is 21.39X2=42.8.  
2. Choose Options->Annotation•••, click Round Rectangle to set the Round to 

43 and 43 respectively.  

3. Move mouse to the 1st point; click its left mouse button to mark it.  
4. Move mouse to the 2nd point, click its left mouse button to mark it, a 

round rectangle with Rr1 and its lengths of the two dimensions will be 

shown.  

Note: User can also annotate round rectangle 1st, then choose Annotation -

>Property••• to adjust the round or to choose Annotation->Select, select 

object to adjust the round rectangle position and size.  
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1.9.9 Ellipse  

The Annotation-> Ellipse menu and its button  on the Annotation Toolbar 

will be enabled only after a new layer above the Background layer is created 

with  Layer->New••• command. In the Layer dialog, the object's Label and Size 

can be checked to hide or show them, the Label’s Color can also be set at 

here.  

Draw Ellipse on the image in layer format   

  

1. Choose Annotation->Ellipse menu.  
2. Move mouse to mark the 1st point.  
3. Move mouse to mark the 2nd point.  
4. If it is not superpose with the shape on the image, choose Annotation-

>Select to adjust the position to get the right shape.  

Note: The object on the image only displays Label and its long and short axis 

length. The other parameters can be found on the Annotation Manager.  
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1.9.10 Circle  

The Annotation->Circle menu and its button  on the Annotation Toolbar 

will be enabled only after a new layer above the Background layer is created 

with  Layer->New••• command. In the Layer dialog, the object's Label and Size 

can be checked to hide or show them, the Label’s Color can also be set at 

here.  

Draw Circle on the image in layer format   

1. Choose Annotation ->Circle->Center+Radius to draw circle with center 

and radius method on the specified layer. Its radius is C1@33583.88um.  

2. Choose Annotation ->Circle->Two Points to draw circle with two point 

method on the specified layer.  

3. Choose Annotation ->Circle->Three Points to draw circle with three point 

method on the specified layer.  

  
Center+Radius  Draw circle with center and radius method on the specified 

layer.  

Two Points  Draw circle with two point’s method on the specified layer.  

Three Points  Draw circle with three point’s method on the specified layer.  

1.9.11 Annulus  

The Annotation-> Annulus menu and its button  on the Annotation Toolbar 

will be enabled only after a new layer above the Background layer is created 

with  Layer->New••• command. In the Layer dialog, the object's Label and Size 

can be checked to hide or show them, the Label’s Color can also be set at 

here.  
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1. Find Annulus center 1 and click mouse button to mark the annulus center.  
2. Move mouse to let the first circle superpose the image circle, click mouse 

button.  

3. Move mouse to let the second circle superpose the circle on the image, 
click mouse button. Two radiuses with number and units will be shown on 

the annulus.  

1.9.12 Arc  

The Annotation->Arc menu and its button  on the Annotation Toolbar will 

be enabled only after a new layer above the Background layer is created with  

Layer->New••• command. In the Layer dialog, the object's Label and Size can 

be checked to hide or show them, the Label’s Color can also be set at here.  

  

1. Move mouse to mark the 1st point.  
2. Move mouse to mark the 2nd point.  
3. Move mouse to mark the 3rd point, then an Arc with Label and its Length 

will be shown near the final point.  

Note: The text indicates the Name and its length. The other parameters can be 

found in the Annotation Manager  
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1.9.13 Text  

The Annotation->Texts menu and its button  on the Annotation Toolbar will 

be enabled only after a new layer above the Background layer is created with  

Layer->New••• command. In the Layer dialog, the object's Label and Size can 

be checked to hide or show them, the Label’s Color can also be set at here.  

  

Draw Text on the image in layer format   

  
1. Choose Annotation->Text menu.  
2. Move mouse to mark the 1st point.  
3. Move mouse to mark the 2nd point, a rectangle with dash line shows the Text 

window size.  

4. Input the text. Click right mouse button to end the Text object. Note: Only 
the input text is shown. The other parameters are name and the center 

coordinate pairs which can be found on the Annotation Manager.  
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1.9.14 Polygon  

The Annotation->Polygon menu and its button  on the Annotation Toolbar 

will be enabled only after a new layer above the Background layer is created 

with  Layer->New••• command. In the Layer dialog, the object's Label and Size 

can be checked to hide or show them, the Label’s Color can also be set at 

here.  

  

Draw Polygon on the image in layer format   

1. Choose Annotation->Polygon menu.  
2. Move mouse to mark the 1st point.  
3. Move mouse to mark the 2nd point.  
•••  

n. Move mouse to mark the nth point.  

n+1. Repeat step1 to n to draw the other Polygon  

Note: For Polygon, the Center, Area and Length will be listed in the Annotation 

Manager.  
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1.9.15 Property•••  
The Property command on the Annotation menu is used to check or modify the 

object Property . Different objects have different Properties.  

  

1. Make a new layer: Annotation->New•••.  
2. Choose Annotation->Polygon to draw Polygon in Fig.1.  
3. Choose Annotation->Property••• to check Polygon Property as show in Fig.2.  
4. Modify the Polygon Appearance Property as shown in Fig.3. Click OK button.  
5. The modified Appearance is shown in Fig.4.  
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1.9.16 Z Order  

Choose Annotation->Z Order or click  on the Annotation Toolbar, then 

select one of the 4 submenus: Top, Bottom, Move Up, and Move Down.  

Create a new layer above the Background layer using Layer->New••• (shortcut: 
Ctrl+N). After 2 or more objects above the image's Background layer are drawn, 
this menu's submenus or its button's submenus on the Annotation Toolbar will 
be enabled. The functions of these 4 submenus are listed below:  

Top  Change the selected object's relative position to the uppermost 
place of all objects.  

Bottom  Change the selected object's relative position to the lowest place 
of all objects.  

Move Up  Change the selected object's relative position to the higher place 
of the two.  

Move Down  Change the selected object's relative position to the lower place 
of the two.  
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1.10 Options  

1.10.1 Preference•••  Shift+P  
There are 4 tabs for the Preference dialog. They are the File, Plugin, Print, 

and Misc tabs.  

File Preference  

One can check a file Extension for the specified file Format and its 

Abbr.(abbreviation), to determine whether it will be displayed in the image 

Browser window or not.  

  

Plugin Preference  

The ToupView installed Plugins will be listed with their Name(s) and dll File 

name(s) in the Plugin menu. If the dll includes Config and About modules, one 

can configure this Plugin and check the About information.  
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Click the left mouse button on the item to highlight it, and Config it 

(supported by the provider, if this function is not provided, the Config 

button will be disabled). One can also find the About information (if this 

function is not provided, the About button will be disabled). ToupView 

currently only provide Line Width, Segmentation, Count, Dimensioning, and FFT 

Plugins as shown below.  

This will create the submenus on the Plugin menu, as shown below:  

  

Print Preference  

One can select the Page Header and Page Footer in following format:  
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&f File Name  

&p Current Page  

&P Total Pages  

%A Full weekday name  

%b Abbreviated month name  

%B Full month name  

%c Date and time representation appropriate for locale  

%d Day of month as decimal number (01 - 31)  

%H Hour in 24-hour format (00 - 23)  

%I Hour in 12-hour format (01 - 12)  

%j Day of year as decimal number (001 - 366)  

%m Month as decimal number (01 - 12)  

%M Minute as decimal number (00 - 59)  

%p Current local times A.M./P.M. indicator for 12-hour clock  

%S Second as decimal number (00 - 59)  

%U Week of year as decimal number, with Sunday as first day of week(00-53)  

%w Weekday as decimal number (0 - 6; Sunday is 0)  

%W Week of year as decimal number, with Monday as first day of week(00-53) 

%x Date representation for current locale  

%X Time representation for current locale  

%y Year without century, as decimal number (00 - 99)  

%Y Year with century, as decimal number  

%z %Z Time-zone name or abbreviation; no characters if time zone is unknown 

%% Percent sign For example:  

&f Date:%Y-%m-%d  
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Page:&p/&P  

Misc Preference   

One can let the application:  

Remind me when save file with draw items not in *.sft format (Checked).  

Remind me when close the window with pending capture.  

Show the start page on the startup (Checked).  

Set "The maximum number of Recent Files: 4" to another number or   

Clear the Recent files when exit the application", or   

Save the current directory in the registry when exit the application.  

  

1.10.2 Annotation•••  
This dialog has many subsections. They are:  

General  

The General tab allows one to select The calculation results keep: X decimals, 

X is between 1 to 6.  

One can also select the Label font size (between 5 and 15).  

Check or uncheck Dimension with unit. If it is checked, the Dimension will 

be displayed together with the units. If unchecked, only the Dimension will 

be displayed.  
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Unit->Length   

Length tab: One can select the length unit for the Annotation menu on the 

layer annotation operation.   

Unit: The system unit defined by the application. It cannot be deleted.  

Current: The unit selected.  

Type: Type of unit. It can be System or User defined.  

Scale: Represents the ratio of "Meter by unit". For example, if the unit is 

µm, then "Meter by µm" should be 1000000, the Scale should be e+6;  
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One can also define his own Unit. Click the Add••• button and the Add Unit 

dialog will be shown. Here, one can enter the unit Name and its Abbreviation. 

In the example below, we named it Decimeter and its Abbreviation is dm, its 

Scale for Meter by Decimeter is 10. Click OK to end the Add operation.  

  

The final Length Unit list looks like the figure below:  

  

Unit->Angle   

On the Angle tab, one can select Radian, Degree, or PI as the angle unit.  
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Point   

Appearance describes the point Size and point Color. The Size is between 2 and 

16. Click the Color button's drop down arrow can select the point Color.  

The Label is for all the layer's Points. Check it here or on the Layer-

>Property••• dialog, the Label will be displayed near the Point for reference. 

Uncheck it, the Label will never be displayed on any layer, even if the Label 

button on the Layer->Property••• dialog is checked.  

  

Line  

The Line tab can set the Line Width, Line Color, Line Style, Arrow shape, and 

determine whether the objects are being labeled or not.  



  

   

  

  

112  

The Label is for all of the layer's Lines. Check it or checks it on the Layer-

>Property••• dialog, the Label will be displayed near the Line for reference. 

Uncheck this button, the Label will never be displayed on any layer, even if 

the Label button on the Layer->Property••• dialog is checked.  

  

Other objects  

The Other items’ setups are  just like the Line object setup, (for simplicity, 

they will not be discussed further). One can learn how to set the other 

objects from ToupView in this menu.  

1.10.3 Auto Correction•••  
Set the low and high ranges for Auto Level and Auto Contrast. The default 

value is 0.5% for both, but ToupView suggests this value be smaller than 1%.  

  

See Image->Adjust->Auto Level and Image->Adjust->Auto Contrast for details.  
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1.11 Window  

1.11.1 Cascade  
The windows menu commands controls the display of images in ToupView. One can 

arrange the display of multiple images in ToupView's workspace.  

Choose Cascade command to arrange the open image windows so that they are 

layered and roughly equal in size, leaving only their title bar and left 

border visible. The Cascade command rearranges only the opened images, Live 

Capture window, and Browser windows.  

1.11.2 Tile  
The window menu commands control how the images are displayed in ToupView. One 

can arrange the display of multiple images in the ToupView workspace.  

Choose Tile command to arrange the open image windows so that all windows are 

visible and roughly equally sized across the screen. Tile images rearranges 

only the opened image, Live Capture video, and Browser windows.  

1.11.3 Arrange Icons  
The window menu commands control how the images are displayed in ToupView. One 

can arrange the display of multiple images in the ToupView workspace.  

If one has some image windows as icons, this command will arrange them into a 

row at the bottom left corner of the ToupView workspace.  

  

1.12 Help  

1.12.1 Help Contents  F1  
Choose this menu to load ToupView help files  

1.12.2 Show Start Page  
Choose this menu to display ToupView Start Page as shown below. Here one can 

directly click on an item to perform operations such as Open Image File, 

Browser Folder for to preview images, and open the device to start the Live 

Capture window. Check Show this start page on startup to open this window 

when ToupView starts.  
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One can also check Show the start page on startup to make the ToupView show 

the start page the next time when ToupView is opened. The 2 check buttons (one 

on the Start Page, the other on the Options->Preferences••• Misc tab), are 

connected.  

Check either of them will check both of them next time.  

  

1.12.3 Check to Update  
This will invoke the Internet Explore and connect to the ToupView update page.  

1.12.4 About•••  
Display the related information about ToupView, including Version, Compatible, 

Built date and its link etc.  

Clicking on WWW will direct one to the www address of the supplier of the 

cameras. In this application, it is http://www.touptek.com. If one has any 
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problem with the camera, please feel free to contact us at 

toupteksales@gmail.com.  
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1.13 Tool Box  

1.13.1 Tool Box Operations Page  
The Tool Box Operations Page is integrated with the Tool Box Layer Page and 

the Tool Box Annotation Page.  

Command: choose View->Tool Box. Click the Operations page. If it is not active, 

click Operations to activate it.  

There are three items on the Tool Box Operations Page, they are  

  

Current  The checked is the Current operating step  

Index  The index of the steps.  

Operations  The operation name of each step.  
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Tool Box Operations Page has the following functions:  

1. Save the Image and Process menu operations in stacks.   

For example, if one open an image and perform the following operations: a) 

Open Image•••  

b) Image->Adjust->Auto Contrast  

c) Image->Invert  

The three steps operations will be listed on the operations' list view as the 

above figure.  

2. Backward will go back to the previous step. Choose Edit->Backward will 
restore the image to the previous step. The Current check box can also 

move backward to the previous step, but the final step is still there.   
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3. Forward will go to the next step. Choose Edit->Forward will change the 
image to the next step. The Current check box can also move to the next 

step, but the 2nd step is still there.  

4. Select Current: Use the mouse button to check the checkbox in the Current 
item.  

5. Extract Button : Extract any of the images in the Tool Box Operations 
Page’s list view as a new image in a new window (Use the mouse button to 
highlight any single step and click the button).  

6. Delete Button : Click the mouse button on the row item will highlight 
any single step. Press down Ctrl+Left mouse button will highlight the 
clicked rows or SHIFT+Left mouse button will highlight the continuous rows 
between the two clicked rows. Click the  button will delete the 
hightlighted items from the Tool Box Operations Page.  

7. Choose Edit->Undo will undo the last step.  

1.13.2 Tool Box Layer Page  
The Tool Box Layer Page is integrated with the Tool Box Operations Page and 

the Tool Box Annotation Page.  

Command: Choose View->Tool Box to display the Tool Box Layer Page. If it is 

not active, click Layer to activate it.  

Use this command to manage layers above the Background layer (image layer).  

There are three items in the Tool Box Layer Page: Visible, Current, and Name   

When an image is opened, a default layer called Background layer is displayed 

in the list view's first row with Visible and Current checked. The Background 

layer cannot be edited. It just tells one that this layer is the basic layer 

for the following Annotation operations.  

  
Visible  Check this checkbox to Show/Hide••• the specified layer.  

Note: when the Current is checked, the Visible checkbox cannot 
be unchecked, meaning the Current layer must be Visible.  
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Current  Check this checkbox to make the Current layer active. When the 
Current is checked, the Visible checkbox will be checked 
automatically.  

Name  Display the layer name, the name cannot be edited. It is specified 
in the Layer->New••• dialog's edit box.  

The basic operations of the Tool Box Layer Page are shown as follows:  

If there is an extra layer above the Background layer, when click the right 

mouse button on the Tool Box Layer Page, a context menu will pop-up. Different 

positions will have different enabled menu items. This enables one to find 

their meanings with ease.  

  

New  Create a New layer. When creating a New layer, one should input 
a layer name and set the layer Property (The default one is 
provided). For simplicity, blank name is accepted.  

Remove  Remove the selected layer (not the Current one, if the check box 
is checked on the Current row, Background layer or blank area, 
this item will be disabled).  

Current  Check the selected row as the active one. When the mouse button 
is on the blank area, this item will be disabled.  
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Show/Hide  Show /Hide the layer which is not active (not the Current layer). 
When the mouse button is on the Background layer or blank area, 
this item will be disabled.  

Property•••  Set this layer object’s property such as Label, Size and Color. 
When the mouse button is on the Background layer or blank area, 
this item will be disabled.  

1.13.3 Tool Box Annotation Page  
The Tool Box Annotation Page is integrated with the Tool Box Operations Page 

and the Tool Box Layer Page.  

Command: Choose View->Tool Box (shortcut Ctrl+T), if it is not active, click 

the Annotation tab to activate it.  

The Tool Box Annotation Page is used to display and modify the Layer object's 

Appearance, Coordinates, and Calculation. An object should be selected first 

to activate the corresponding items.  

Note: One can only check a single object at a time.  

Appearance  Used to display and modify the layer object's style, including 
Line Width, Line Color, and Line Style. It will also display 
Arrow1 and Arrow2 for a Line object. By clicking the mouse 
button, one can select or change the object's Appearance.  

Coordinates  Display and modify the selected object's Coordinates. When the 
object is a complex object, the Coordinates can be displayed 
according to the drawing order. The main complex objects are 
Angle, Parallel Line, Vertical Line, and Circles with the same 
Center.  

Calculation  Calculation will give the object's geometric dimensions. For 
example, a Line object will have the following information: 
Start and End point coordinates, Length, Slope, and Angle.  

An annotation example is given below:  

1. Choose Open Image to open an image.  

2. Choose Layer->New••• to make a new layer.  

3. Choose Annotation->Circle->Two Points and draw a Circle on the image. Select 

the Annotation object. Open the Tool Box Annotation Page, View->Tool Box 

(shortcut Ctrl+T). The Tool Box Annotation Page should look like this:  
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One can change or modify any items with ease here.   
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1.14 Annotation Toolbar  

  

Please check the Annotation menu for more details.  

1. Image Select: See Process Frame: Annotation->Image Select.  

2. Zoom In(Ctrl++): Click this button to Zoom In the image.  

3. Zoom: See Process Frame: Annotation->Zoom.  

4. Zoom Out(Ctrl+-): Click this button to Zoom Out the image.  

5. Zoom Tool: See Process Frame: View->Zoom Tool.  

6. Track: See Process Frame: View->->Track.  

7. Object Select: See Process Frame: Annotation->Object Select.  

8. Angle: See Process Frame: Annotation->Angle.  

9. Point: See Process Frame: Annotation->Point.  

10. Line:  See Process Frame: Annotation->Line.  
11. Parallel: See Process Frame: Annotation->Parallel.  
12. Vertical: See Process Frame: Annotation->Vertical.  
13. Rectangle: See Process Frame: Annotation->Rectangle.  
14. RoundRect: See Process Frame: Annotation->RoundRect.  
15. Ellipse: See Process Frame: Annotation->Ellipse.  
16. Circle: See Process Frame: Annotation->Circle.  
17. Annulus: See Process Frame: Annotation->Annulus.  
18. Arc: See Process Frame: Annotation->Arc.  
19. Text: See Process Frame: Annotation->Text.  
20. Polygon: See Process Frame: Annotation->Polygon.  
21. Property: See Process Frame: Annotation->Property•••  
22. Z Order: See Process Frame: Annotation->Z Order.  
23. Print: See Process Frame: File->Print•••.  

  

1.15 Process Frame Statusbar  
The Process Frame Statusbar is shown below. It has 6 items and they are:  
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1. File name and its directory.  

2. Image width and height of the opened image.  

3. Current Zoom ratio. Clicking on the icon with the right mouse button will 
cause a Zoom Context Menu to pop-up. Here, the Zoom ratio can be selected 

with ease.  

4. The selected area on the image, which includes the start point in the upper 
left corner and the area width and height.  

5. The current horizontal or vertical ruler’s length between two numbers in 
the image window. See the annotation in the figure below.   

  

Double click this icon will invoke a Process Frame: Options->Annotation••• -
>Length tab and one can check the Unit or define the new Unit.  
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Click the Unit with the right mouse button will pop-up the Unit context menu. 

Here, the different Unit can be selected with ease. One can also Customize 

the  

Unit by choose Customize•••menu, this will be the same as double clicks 
operation.   

6. Current image’s Color Bits and Resolution in the width and height 
directions.   
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2 Live Capture Frame  

2.1 Live Capture Frame Introduction  
The Live Capture Frame is specially designed for camera video. It includes:  

1. Live Capture menu  

2. Start Frame Toolbar: See Start Frame: Start Frame Toolbar  

3. Live Capture Toolbar: See Live Capture Frame: Live Capture Toolbar  

4. Live Capture Window: See Live Capture Frame: Acquire menu  

5. Live Capture Statusbar: See Live Capture Frame: Live Capture Statusbar These 

features are shown in the figure below:  
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2.2 File  

2.2.1Open Image•••  Ctrl+O  
See Process Frame: File->Open Image•••.  

2.2.2 Open Video•••  
See Process Frame: File->Open Video•••.  

2.2.3 Paste as New File•••  
See Process Frame: File->Paste as New File•••.  

2.2.4 Print Setup•••  
See Process Frame: File->Print Setup•••.  

2.2.5 Recent File  
See Process Frame: File->Recent File.  

2.2.6 Exit  
See Process Frame: File->Exit.   
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2.3 Acquire  

2.3.1Live Capture 
See Process Frame: Acquire->Live Capture.  

2.3.2 Software Power  
See Process Frame: Acquire->Software Power.  

2.3.3 Manage Software Power•••  Ctrl+M  
See Process Frame: Acquire->Manage Software Power•••.  

2.3.4 Video Marker•••  
See Process Frame: Acquire->Video Marker•••.  

2.3.5 Video Overlay Text•••  Ctrl+D  
See Process Frame: Acquire->Video Overlay Text•••.  

2.3.6 Video Watermark•••  Ctrl+W  
See Process Frame: Acquire->Video Watermark•••.  

2.3.7 Auto Maximum Size•••  Ctrl+U  
See Process Frame: Acquire->Auto Maximum Size•••.  

2.3.8 Capture with Marker and Watermark  Ctrl+F  
See Process Frame: Acquire->Capture with Marker and Watermark.  
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2.3.9 Twain:Select Device•••  
See Process Frame: Acquire->Twain:Select Device•••.  

2.3.10 Twain:Acquire•••  
See Process Frame: Acquire->Twain:Acquire•••.  

  

2.4 View  

2.4.1Browser   Ctrl+B  
See Process Frame: View->Browser.  

2.4.2 Tool Box  Ctrl+T  
See Process Frame: View->Tool Box.  

2.4.3 Annotation Manager See Process 

Frame: View->Annotation Manager.  



ToupView Help  

  
  

130  

  

2.5 Setup  

2.5.1Full Screen   Esc  
Choose the Full Screen to display the Live Capture window in full screen 

style. Press ESC to enter Full Screen mode. Press ESC again will return to 

the default Live Capture window.  

2.5.2 View Property•••  
View Property will help to understand the camera statistical properties. 

Choose Setup->View Property••• to invoke the View Property dialog:  

  

The items in the dialog are described in the following table:  

Item  Description  

Device ID  Unique ID to identify the camera device.  

Device Name  Human readable string to identify the model of the 
camera device.  
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Still Image Capture  Whether or not the camera supports Still Image 
Capture. Still Image Capture is used for high 
resolution camera to capture an image with a 
different resolution from the video. This feature 
is mainly used to capture high resolution image 
under low resolution video to compromise the frame 
speed and the image resolution.  

Display Width  The Live Capture window width.  

Display Height  The Live Capture window height.  

Video Width  The actual Live Capture window video width.  

Video Height  The actual Live Capture window video height.  

Compression  The compression format of the video stream.  

Bits Per Pixel  Indicate how many bits are used to store on pixel.  

Time (second)  Seconds elapsed since the Live Capture has been 
started.  

Frame  Frames acquired since the Live Capture has been 
started.  

Actual Frame Rate  Actual frame Rate of the Live Capture stream.  

Note: The Actual Frame Rate is listed for reference. It varies depending on 

the computer's configuration. Different hardware configurations may have 

different Actual Frame Rates.  

2.5.3 Video Source Property•••  
Choose Setup->Video Source Property••• to invoke the Video Source Property 

dialog:  
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The Video Source Property includes several categories: Color, Exposure, 

Extended, Misc and ROI.  

2.5.3.1 ROI:   
White Balance and Auto Exposure are performed within the ROI, which require 

a correctly defined region of interest (ROI), so ROI is described first.  

The region with the slanted grid background represents the whole video region. 

The region with the normal grid background represents the ROI. The ROI can 

be manipulated according to its relative position with the mouse.  
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Mouse Cursor  Operation  

  

Mouse cursor becomes this when the mouse is near the up or down 
edge of the ROI. Click the mouse and drag, the ROI can be 
extended or reduced along the vertical direction.  

  

Mouse cursor becomes this when the mouse is near the left or 
right edge of the ROI. Click the mouse and drag, the ROI can be 
extended  

  

  

Whole video area   

ROI   
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 or reduced along the horizontal direction.  

  

Mouse cursor becomes this when the mouse is in the whole video 
region but not in or near the ROI. Click the mouse and drag, a 
new ROI will appear.  

When the Video Source Property dialog is opened, a region will blink on the 

video window if the ROI is correctly defined. The blinking region is used to 

help one to adjust the ROI.  

2.5.3.2 Color  
Although all ToupTek digital cameras are colorimetrically characterized to 

produce the most pleasing video and image, some environmental and personal 

preference related tunings are left for the customer to obtain the most 

natural scenario and make full use of the system capability. On the Color 

property page, there are 3 groups of parameters to adjust: White Balance,  

Hue/Saturation/Brightness and Contrast/Gamma. These parameters mainly control 

the color representation of the acquired video and captured image.  

  

White Balance:   

Human eyes have the ability of color constancy, so white objects under 

illuminations with different color temperatures also appear white when 

observed with human eye. Digital cameras don’t have this ability. They only 

loyally record the optical information of the incident light. This circumstance 

leads to the mismatch of the observation between human eyes and digital 

cameras. White balance is used to solve this problem. ToupView offers two ways 

to adjust the white balance: manual and automatic.  
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To adjust the white balance manually, drag the Temperature and Tint sliders 

until a satisfactory result is obtained. There are two tips to perform manual 

white balance:   

1. Drag the Temperature slider to the left side will make the video appear 

blue while drag the Temperature slider to the right side will make the video 

appear red;   

2. Drag the Tint slider to the left side will make the video appear magenta 

while drag the Tint slider to the right side will make the video appear green.  

To adjust the white balance automatically, one should define the ROI first. 

Switch to the ROI page and drag the ROI rectangle to a white region of the 

object and switch back to Color page. Click the One Push button in the White 

Balance group. ToupView will analyze the image in the ROI and adjust the 

Temperature and Tint automatically. If one wants to view the original 

representation of the object, click Default button in the White Balance group. 

The effect of the automatic white balance is shown below:  

  

Hue/Saturation/Brightness:  

Hue/Saturation/Brightness tuning is performed in the HSB color space.  

Change the hue will change the color map between the real color of the image 

and the displayed color. The following picture will illustrate this:  

  

The upper color bar represents the real color and the lower color bar 

represents the displayed color. Before performing hue tuning, the map between 

is shown above.  

After hue tuning, the map is shown below:  

  

Apparently the map is changed. An image applied hue tuning and its original 

version are listed below:  

Colorimetric characterization only makes the image look as close to the real 

scenario as possible. To obtain a more pleasing image, saturation can be 
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tuned. Drag the Saturation slider to the left will make the image look less 

vivid while to the right more vivid. ToupTek color scientists already assigned 

a default value for this before shipping; however, one can change this value 

arbitrarily.  

  

Brightness tuning is not recommended for two reasons: this operation will 

introduce digitization error and the tuning effect can be accomplished via 

exposure tuning. Instead, Exposure Time and Analog Gain are recommended. 

However, one can still change it.  

Contrast/Gamma:  

Some old or uncalibrated CRTs and LCDs need this tuning to compensate the 

disabilities of the computer monitor. One can change them according to the 

monitor.  

Tips: 1. Drag the Contrast slider to the left side will decrease the contrast 

and vice versa; 2. Drag the Gamma slider to the left will make the image look 

brighter and vice versa.  
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2.5.3.3 Exposure  

  
On the Exposure property page, there are two groups of parameters to adjust: 

Exposure and Vignetting. The parameters in the Exposure group are used to 

control the hardware of the digital camera to obtain the properly exposured 

video and image, while the parameters in the Vignetting group are used to 

compensate the different exposures caused by the vignet of the camera lens.  

Exposure:  

Two parameters can be adjusted for Exposure tuning: Exposure Time and Analog 

Gain. Exposure Time is the time slice during which the sensor collects the 

incident light. The longer the Exposure Time, the brighter the video and 

image appears. Analog Gain is the factor used to multiply the image signal 

in the analog domain of the camera hardware, which will introduce less noise 

than digital gain. ToupView offers two ways to tune the exposure: automatic 

and manual.  

To adjust the exposure automatically, check the Auto Exposure check box and 

drag the Target slider to the desired intensity value. Exposure Time and 

Analog Gain are adjusted automatically according to the image contents in the 

ROI until the average intensity of the ROI reaches the Target value. When the 

Auto Exposure check box is checked, one can move the ROI to any region of the 

image to make that region expose correctly.  

To adjust the exposure manually, uncheck the Auto Exposure check box. Drag 

the Exposure Time or the Analog Gain slider to the left side if the video 

appears too bright and vice versa.  

Tip: Whenever possible, keep the Analog Gain as low as possible. Higher Analog 

Gain will introduce more noise.  
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Vignetting:   

Image Vignetting is a phenomenon observed in photography which introduces 

some photon energy loss on the periphery of a video or captured image. This 

is translated into a lower color intensity of the pixels of the area where 

the phenomenon appears. Typical vignetted image and its Vignetting corrected 

version are shown below:  

  

The Amount parameter represent the compensation amount, a negative value 

means brighter corner (than the center area) will be compensated as bright 

as the center area while a positive value means darker corner (than the center 

area) will be compensated as bright as the center area. The MidPoint parameter 

is used to control the compensation radius. A smaller value means larger 

corner areas outside of this radius are compensated while a larger value 

means smaller corner areas outside of this radius are compensated. In the 

following images, the Amount of left image is 100, the MidPoint is 0; the 

Amount of right image is 100, the MidPoint is 100:  

  

2.5.3.4 Extended  
Level stretching function is provided for red, green, blue, gray and RGB 

channels separately in the Extended property page. Experienced photographer 

can easily obtain the pleasing effect according to the histogram. The 

operation is easy, dragging the vertical magenta line across the histogram 

and dropping it at the desired location. The level between the two vertical 

lines will be stretched. Note: No matter which channel is selected, auto 

level stretching will analyze the RGB channel of the histogram and calculate 
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the desired level. One point should be kept in mind: Click the Refresh button 

each time the sample is moved, changed the objective or did some parameters 

tuning. Images before and after level stretching are shown below:  

  

2.5.3.5 Misc  
On the Misc property page, there are four groups of parameters can be adjusted: 

Frame Speed Level, Light Frequency, Flip and Mode.  

Frame Speed Level is used to adjust the frame speed of the video. The higher 

the Frame Speed Level, the higher the frame speed and vice versa. ToupView 

will automatically detect the proper Frame Speed Level the first time the 

digital camera runs on the computer. However, if one changes the Frame Speed 

Level manually, ToupView assumes the best Frame Speed Level for the computer 

is selected and will NEVER detect the proper Frame Speed Level automatically.  

  

If the illumination light uses alternative current power supply, horizontal 

stripes may appear on the video for CMOS sensor digital cameras, because CMOS 
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sensor uses electronic rolling shutter. Light Frequency parameter is used to 

prevent this phenomenon.  

Flip can easily mirror the video either vertically or horizontally. Mode 

can switch the video between Polychromatic and Monochromatic.  

2.5.4 Video Stream Format•••  
The ToupView Video Stream Format••• configuration dialog is shown below:  

  
One can change the video format mode, frame rate, color space, compression 

options and so on. Here, we only have the Video Size to check. Check the 

desired one and click OK. This will give one the selected Live Capture Video 

Size. Click Cancel and the selection will be ignored and the dialog will 

close. Clicking Apply will apply the current selection to the Live Capture 

Video but the dialog will remain opened.  

Note: Different devices may have different user interfaces and items. Contact 

the camera supplier for details.  

2.5.5 Still Image Options•••  
Some cameras can produce a still image separate from the capture stream. 

Often the still image is of higher quality or larger size than the images 

produced by the capture stream (Live Capture). The camera may have a button 

that acts as a hardware trigger, or it may support software triggering. A 

camera that supports still images will expose a still image pin.  

To capture a still image, one should first set the size of the image to 

capture. The size is determined by the camera hardware. Here we show an 

example with the UCMOS08000KPA camera.  

Choose Setup->Still Image Options••• will show the following Properties 
dialog:  
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It has 3264*2448, 1600*1200, and 800*600 resolutions. Check the desired one 

and press OK to accept the selection or Cancel to ignore the current 

selection. Click Apply to apply the selection.  

One can check if the device supports Still Image Capture or not by choose 

Setup->View Property•••.  

If the Still Image Capture's Value is Y in the View Property dialog, this 

means that UCMOS08000KPA supports the Still Image Capture operation. The Y 

will enable the menu Setup->Still Image Options••• and the  button on the 

Live Capture Toolbar. The N will disable both of them.  

The other items describe the current Live Capture window size, the size of 

the still image that will be captured. The Live Capture video size can be set 

in Setup->Video Stream Format•••.  
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2.6 Capture  

2.6.1 Capture a Frame  Ctrl+V  

Capture a Frame (shortcut: Ctrl+V or click ) will capture a frame from the  

Live Capture video stream and open it in a new window.  

2.6.2 Capture to Clipboard  Ctrl+C  
Capture to Clipboard (shortcut: Ctrl+C) will copy a frame from the Live 

Capture video stream to the clipboard for further application.  

2.6.3 Time-lapse(Auto Capture)•••  

The Time-lapse (Auto Capture)  command enables the use of the Time-lapse 
(Auto  

Capture) function together with an appropriate time interval. This function 

triggers the images capture at adjustable, regular intervals.   

Auto Capture Procedure  

1. Choose Capture->Time-lapse (Auto Capture)••• or click  button. The Time-

lapse (Auto Capture)••• dialog is shown below:  

  

Input the Directory where one will save all of image files. One can use  

to locate the Directory.  
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In the File section, one can choose Name Format. There are 4 formats, they 

are: yymmddHHMMSS, yyyymmHHMMSS, yy-mm-dd-hh-mm-ss, and yyyy-mm-dd-HH-MM-SS. 

The File Prefix will be attached in front of the Name Format. One can also 

choose File Type in bmp, jpg, png, or tif format. The File Type will be used 

as the file extension. The file extensions jpg, png, and tif have their own 

file Option. The final name in this Time-lapse (Auto Capture) will be TP-

yyyymmHHMMSS.png. This mechanism ensures that the previous image will not be 

overwritten when capturing a new one.  

Click the Option button and the Option dialog corresponding with file 

extension will pop-up for adjustment. For jpg, the Option dialog is:  

  
Image quality  If one save an image in JPEG format (*.jpg), one may 

adjust image quality in the edit box. The values range 
from 0 to 100. Default value: 75.  

Progressive  The default is unchecked.  

Optimize Huffman codes  The default is unchecked.  

Smoothing  The values range between 0 and 100. Default value: 0.  

Save these setting as 
defaults  

When saving a file, the current settings will be saved 
as defaults for the next file save operation.  

For png, the Option dialog is:  
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Interlaced  The default is unchecked.  

Save these setting 
as defaults  

When saving a file, the current settings will be saved 
as defaults for the next file save operation.  

For Tag Image File Format(*.tif, *.tiff), the Option has the following items:   

  

Appended pages  
Determine whether the current image will be saved in 
multiple pages style or not.  

Compressions  

Specifies a method for compressing the composite image 
data.  

For saving a 32‑ bit TIFF file, one can specify that the 
file be saved with predictor compression, but have no 
option to use JPEG compression. Predictor compression 
offers improved compression by rearranging floating point 
values, and works with both LZW and ZIP compression.  

Image quality  

If choose Compressions as "JPEG", the Image quality can 
be adjusted by the slider bar. The values range between 
0 and 100. Default value: 75.  

Save these setting 
as defaults  

When saving a file, the current settings will be saved as 
defaults for the next file save operation.  
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The Time slot (seconds) is used to set the interval of the Auto Capture 

between 2 frames. The minimum is 2s and the maximum is 3600s. Any time beyond 

this range will invoke a warning dialog indicating the correct time interval 

range.  

Check Limit the total times will restrict the total times that the Time-lapse 

(Auto Capture) process occurs. It should be between 1 and 999. Uncheck this 

button, the frame will be captured continuously until one clicks Time-lapse 

(Auto Capture) again to cancel the last Time-lapse (Auto Capture) process.  

If everything is ok, press the OK to begin Time-lapse (Auto Capture).  

2. In the Time-lapse (Auto Capture) process, the dynamic information will be 

shown on the Statusbar. They are:   

  

1) Live Capture camera name;  
2) Process name;   
3) Time slot;   
4) Frames captured and the total frames;  

3. When Time-lapse (Auto Capture)••• is started, the Capture->Time-lapse 

(Auto Capture)••• menu will be checked. One can unchecked it if one want to 

stop the Time-lapse (Auto Capture)••• process. After the Time-lapse (Auto 

Capture)••• process is finished, it will be unchecked to start a new Time-

lapse (Auto Capture)••• process.  

2.6.4 Capture Still Image•••   Ctrl+Z  

Choose Capture->Capture Still Image (shortcut: Ctrl+Z) or click  on the Live 

Capture Toolbar.)  

Some cameras can produce a still image separate from the capture stream, and 

often this still image is of higher quality or larger in size than the images 

produced by the capture stream (Live Capture video). The camera may have a 

button that acts as a hardware trigger, or it may support software triggering. 

A camera that supports still images will expose a still image pin.  

To support the still image capture, ToupView can enumerate the device's 

capability and make Capture Still Image button  enable on the Live Capture 

Toolbar.  

Choose Setup->View Property••• to check if the camera supports still images 

or not.  

In the example below, since the Still Image Capture's value in View Property 

dialog is Y, this means UCMOS080000KPA supports the Still Image Capture.  
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The Still Image size can be set in Setup->Still Image Options •••.  

2.6.5 Capture Still Image to Clipboard   Ctrl+Y  
Choose Capture->Capture Still Image to Clipboard (shortcut: Ctrl+Y).  

Some cameras can produce a still image separate from the capture stream, and 

often this still image is of higher quality or larger in size than the images 

produced by the capture stream (Live Capture video). The camera may have a 

button that acts as a hardware trigger, or it may support software triggering. 

A camera that supports still images will expose a still image pin.  

To support the still image capture, ToupView can enumerate the device's 

capability and make Capture Still Image button  enable on the Live Capture 

Toolbar.  

Choose Setup->View Property••• to check if the camera supports still images 

capture or not   

In the example below, since the Still Image Capture's value in View Property 

dialog is Y, this means UCMOS080000KPA supports the Still Image Capture 

operation.  
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2.6.6 Start Capture Video•••  
This command will start capturing a video. When one chooses the Start Capture 

Video••• command, a wizard will pop-up for one to configure it step by step. 

1. Select the video format, either wmv/asf or avi. We recommend using wmv/asf.  

Once one make selection, click Next > to proceed. Click < Back to return to 

the previous setup dialog or click Cancel to cancel the Start Capture Video••• 

command.  

  

2. Set the file name and file directory; use Browser••• to locate the 
directory.  

If everything is ok, click Next> to proceed. Click <Back to return to the 

previous setup dialog or click Cancel to cancel the Start Capture Video••• 

command.  
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3. Set the Encoder and Encoder Parameter. The Encoder is the algorithm used 
to compress the video. ToupView can enumerate all of the Encoders installed 

and put them into the list box as shown.   

Select this by click the dropdown arrow and choose it with the mouse button. 

Also, one can modify Quality (1-100) value in the edit box.  

If everything is ok, click Next > to proceed, click < Back to return to the 

previous setup dialog or click Cancel to cancel the Start Capture Video 

command.  

  

4. Set the desired Display Information as show in the following dialog. They 
are   

Title: The Title of the capture video.  

Author: Who is the author of this video?  

Copyright: The Copyright of this video.  
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Description: The other information the author may wish to save in the video.  

All the display information is optional.  

  

5. The final dialog will be as follow. The only parameter one needs to set is 
Time Limit (Minutes). Check this item need to input the total time. Uncheck 

it means the time is unlimited.  

The Summary shows all the items selected or set.  

If everything is ok, click Finish to begin the video capture. Click <Back to 

return to the previous setup dialog or click Cancel to cancel the Start 

Capture Video••• command.   

  

6. When video capture is started, the Capture->Start Capture Video••• will be 
grayed and Capture->Stop Capture Video will be enabled. Choose the latter 

one if one wishes to end the video capture.  
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2.6.7 Stop Capture Video  
This menu will be enabled when choose Capture->Start Capture Video••• command 

and begin the video capture   

To stop capturing the video stream, Choose Capture->Stop Capture Video.  
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2.7 Options  

2.7.1Preference•••  Shift+P  
See Process Frame: Options->Preference•••.  

2.7.2 Annotation•••  
See Process Frame: Options->Annotation•••.  

2.7.3 Auto Correction•••  
See Process Frame: Options->Auto Correction•••.   
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2.8 Window  

2.8.1Cascade  
See Process Frame: Window->Cascade.  

2.8.2 Tile  
See Process Frame: Window->Tile.  

2.8.3 Arrange Icons  
See Process Frame: Window->Arrange Icons.   
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2.9 Help  

2.9.1Help Contents  F1  
See Process Frame: Help->Help Contents.  

2.9.2 Show Start Page  
See Process Frame: Help->Show Start Page.  

2.9.3 Check to Update  
See Process Frame: Help->Check to Update.  

2.9.4 About••• See Process 

Frame: Help->About.  
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2.10 Live Capture Toolbar  

  

The Live Capture Toolbar is specially designed for Live Capture window by 
ToupView.  

Its main functions are very useful to perform processes on the Live Capture 
window.  

They are:  

2.10.1 Capture a Frame   
See Live Capture Frame: Capture->Capture a Frame menu.  

2.10.2 Capture Still Image   
See Live Capture Frame: Capture->Capture Still Image menu.  

2.10.3 Time Lapse(Auto Capture)   
See Live Capture Frame: Capture->Time-Lapse(Auto Capture)••• menu.  

2.10.4 Software Power   
See Process Frame: Acquire->Software Power menu.  

2.10.5 Zoom  

Toolbar button . The Live Capture window can sometimes be too large 

to see the whole video for a high resolution camera. In this case, one can 

click arrow button on the right of this Zoom button and select one of the 

items to set the Live Capture window to the proper size. Its dropdown list 

box looks like:  

  

2.10.6 Start  
If the Live Capture window is paused, one can continue the Live Capture 

process by check this button and the Pause button will be enabled.  
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2.10.7 Pause  
If the Live Capture window is running, one can Pause the Live Capture process 

by check this button and the Start button will be enabled.  

2.10.8 Arrow key to move marker or watermark  

 Arrow key to move marker or watermark toolbar button .The Live Capture 

window can display the Video Marker and Video Watermark; one can move them 

with the keyboard arrow keys or its submenus. The Arrow key to move marker 

or watermark’s submenus are  

  

There are two methods to move the Video Marker and Video Watermark  

1. Move the Video Marker and Video Watermark using keyboard arrow keys.  

When this button is checked, one can move the Video Marker and Video Watermark 

to the desired position with the up, down, left and right arrow keys.  

2. Move the Video Marker and Video Watermark using submenus.  

Marker Move to•••  

Choose this menu will display a Move dialog, where one can enter the X and Y 

coordinates of the desired coordinates.  

  

Marker Move to zero  

If the Video Marker was moved, choose this menu will return the Video Marker 

to its original coordinates (0,0).  

Watermark Move to•••  

If the Video Watermark is displayed, this menu will be enabled. Choose this 

menu will display a Move dialog, where one can enter the X and Y coordinates 

of the desired location.  
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Watermark Move to zero  

If the Video Watermark was moved, choose this menu will return it to its 

original coordinates (0,0).  

2.10.9 Arrow key to rotate watermark   

Arrow key to rotate watermark toolbar button .The Live Capture window 

can display the Video Watermark and allow one to rotate it with the keyboard 

arrow keys or submenus. The Arrow key to rotate watermark button’s submenus 

are shown as below:  

 There 

are two methods to move the Video Watermark:  

1. Rotate Video Watermark using keyboard arrow keys:  

When this button is checked, one can rotate the Video Watermark to the desired 

angle with the left and right keyboard arrow keys.  

2. Rotate the Video Watermark with submenus:  

Rotate to•••  

Choose this menu will display a Rotate dialog, where one can enter the angle 

to Rotate the Video Watermark to the desired angle.  

  

Rotate to zero  

If the Video Watermark was rotated, Rotate to zero will be enabled. Choose 

this menu will return the Video Watermark to zero degree.  

2.10.10 Define Software Power Why 

Software Power?  
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Toolbar button . Microscopes with 4X, 10X, 40X, and 100X objectives means 

that it has four different optical powers.  

However, if this microscope is combined with different digital cameras to 

capture the images, the magnification of the captured images is no longer the 

same as the magnification of the objective. Instead, it is represented by the 

Resolution, which is determined by the Software Power of the entire system 

(microscope plus digital camera).  

How to define the Software Power?  

For consistency, a menu called Software Power with some submenus named 4X, 

10X, 40X, and 100X is designed to denote the Resolution. Therefore, these 

Software Powers are actually the system powers (microscope plus digital 

camera), corresponding to the image Resolution.  

When the Software Powers are defined, the Software Powers can be selected in 

ToupView according to the actual microscope objective. After the image has 

been captured, the Resolution can be saved together with the image data.  

If one wants to measure the object's size on the image, ToupView will 

automatically calculate the object's size according to the Resolution and the 

selected Units for further analysis.  

So the first step is to define the Software Power. Different microscope and 

digital camera combinations need to define a set of Software Powers first.  

About the Micro Ruler  

(Note: One need to have a micro ruler with minimum increment of 0.01mm or 10µm 

to Define Software Power. Its overall length is 1mm. It is recommended that 

the stage micrometer or scale used in the calibration should be traceable to 

the National Institute of Standards and Technology (NIST) or a similar 

organization.).  

The steps to Define Software Power are as follows:  

  

Define Software Power  

Step 1: Start the ToupView   



ToupView Help  

158  

1. Plug the camera (UCMOS or UHCCD camera for microscope) into the 

trinocular or C-Mount interface of a microscope.  

2. Plug the USB connector to the computer USB port (For USB2.0 cameras, 

be sure to plug it into the correct port, some computers only have a single 

USB2.0 port). 3. Run ToupView.  

4. Put the micro ruler on the microscope’s stage, move the ruler to the field 

center and focus it to see it clearly.  

Step2: Invoke Live Capture and select the default Software Power "Pixel"  

1. Start the Live Capture: One has 3 methods to start Live Capture:  

a). Select Acquire->Live Capture•••.  

b). Click the Live Capture button  on the Live Capture Toolbar and 

select the right camera.  

c). Click on the camera name on the Start Page (Process Frame: Help->Show 

Start Page).  

2. Click the dropdown arrow on the Software Power button  on the  

Live Capture Toolbar to list the Software Power. If no Software Power was 

defined before, there is only the default Pixel item. Select Pixel as the 

Software Power at this time.  

  

Step 3: Define Software Power  
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1. Switch the microscope's objective to the one that wish to define(for 

example 10X at first, or the other 4X, 40X,100X ), focus the micro ruler to 

get a clear image, move the ruler to the Live Capture window center, and let 

it align horizontally with the cross cursor. The Live Capture window should 

look like above:  

2. Click the Define Software Power button  and choose Horizontal Line. 

(The other two modes can be also chosen according to the direction of the 

micro ruler)  

   
The Live Capture window should look like this:  

  

3. Put the cursor at the Start Point (align the cursor vertical line with 

the micro ruler vertical line) and click the mouse button. The point will be 

marked with a small cross. Move the mouse and let align the cursor vertical 

line with the micro ruler vertical line, click the mouse button again, and 

the End Point will be marked. The final screen should look like the following:  

  

4. When the mouse button is released in the above End Point, a Define 

Software Power dialog will be shown below.   
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Here, type 10 in the Software Power edit box. The Actual Length between the 

Start and End point is 650um. After the Actual Length edit box is filled, the 

Resolution will be filled automatically according to the calculation. Now the 

Define Software Power dialog should be   

  

Click OK to end the 10X Software Power definition.  

Step 4: Repeat Step 3 to define the other Software Powers.  

Switch the microscope's objective to the undefined one, repeat Step 3 to 

define the other Software Power. The final Software Power dialog for the 

microscope and camera system should look like below:  
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Here one can Delete••• (After the item is selected, click the Delete••• 

button.) and change the Software Powers list order to the desired one (Select 

the item and click either the Up or the Down button).  

Now the Acquire->Software Power submenus should look like this   

  

The Software Power button on the Live Capture Toolbar should look like this  

   

2.10.11 Gray Calibration  

Toolbar Icon: . Gray Calibration is a useful function to help one to get 

the average gray value of the selected region. Click the toolbar icon, the 

mouse cursor will become a blue cross. Click at the interested rectangle area 

Start Point and then move the mouse cursor to the End Point of the interested 

rectangle area as below:  

  

Click at the End Point, a dialog will open and the rectangle area will be 
blinking.  
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The average gray value of the selected area is shown in the dialog. This 

average gray value can be adjusted by adjust the light intensity or adjust 

the Exposure time or the other camera parameters on the Setup->Video Source 

Property••• menu.  

2.10.12 Auto Focus   

Auto Focus toolbar button   

Auto Focus Prerequisites  

1. Make sure that the ToupView packages and drivers of step motor and 

UCMOS or UHCCD camera is installed correctly.  

2. Plug in all of the devices' cables and turn on the step motor controller 

and microscope light.  

Auto Focus Procedure  

Step 1. Select Acquire->Live Capture or click  and then choose the 

digital camera to open the Live Capture window. One can also open the Live 

Capture window from the Start Page.  

Step 2. Select the proper Software Power from the list  on the Live  

Capture Toolbar and let this Software Power equal to the real microscope's 

objective power to realize the auto-focus function.  

Step 3. Click the button  to start the auto-focus process. During the 
process,  
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one can click the  button again to stop it.  

Step 4. If one switch objective, repeat step 2 and to start the Auto Focus 

again for the new objective.  

Some Important Information about the Auto Focus Process   

1. If Auto focus when start device is checked in the Options->Preference-

>Focus tab, the auto-focus function will be executed after step 1 in the Auto 

Focus Procedure is done.  

2. If Auto focus when switch the software power is checked in the Options-

>Preference->Focus tab, the auto-focus function will be executed after step 

2 in the Auto Focus Procedure is done.  

3. If one wants to do the auto-focus function without changing the real 

microscope's objective, one can run step 3 in the Auto Focus Procedure 

directly to perform the Auto Focus operation.  

2.10.13 Manual Focus  Manual 

Focus toolbar button  Manual 

Focus Prerequisites  

1. Make sure that the ToupView packages, step motor driver and UCMOS or 

UHCCD camera is correctly installed.  

2. Plug in all of the devices' cables and Turn on the step motor controller 

and microscope power.  

Manual Focus Procedure  

1. Select Acquire->Live Capture or click  and then choose the digital 

camera to open the Live Capture window. One can also open the Live Capture 

window from the Start Page.  

2. Click the button  to start the manual focus dialog as shown below:  
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The two left buttons  in this dialog represent coarse focus  

(keyboard shortcuts: Ctrl/Shift +PageUp, Ctrl/Shift +PageDown), and the two  

right buttons  represent fine focus (keyboard shortcuts: PageUp, 

PageDown). Click Settings… button will open Options->Preference->Focus tab.  

3. To stop the manual focus process, please click (keyboard shortcut:  

Delete).  

2.10.14 Auto Fusion   

Image Fusion toolbar button:    

Function Prerequisites  

1. Make sure the ToupView packages, drivers of step motor, and UCMOS or 

UHCCD cameras are correctly installed.  

2. Plug in all of the devices' cables and turn on the step motor controller 

and microscope light.  

Image Fusion Procedure   

Step 1. Click the Live Capture Toolbar button  and the following dialog 

will be shown:  

  

The Step Number and Step Length are set according to the sample’s thickness 

and richness in detail as well as the object’s magnification.  

Step 2. Click the Start button and the application will capture images to do 

the fusion according to the Step Number and Step Length. When the capture is 

finished, the object stage will reset to its original z position.  

 and  
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Step 3. Click the Test Run button and the system will do a dummy run to see 

if the Step Number and Step Length are correct. During this process, the 

image capture and fusion will not be processed. When the operation is 

finished, the object stage will reset to its original position.  

Step 4. During the Fusion calculation and Test Run process, the Cancel button 

can be clicked at any time to cancel this operation. However, the object 

stage will not be able to return to its original position under this 

circumstance.  

Step 5. The progress bar will run two times after clicking the Start button: 

the first time for image capture, and the second for image fusion. However, 

in the Test Run, it will run only once.  

Step 6. The whole image fusion process is illustrated as the movie in the 

bottom right corner of the dialog.  

Image Fusion Key Points for Reference   

1. Before doing the Image Fusion, move the object stage until it reaches 

the place closest to the objective, and make sure there is at least one clear 

region in the field of view.  

2. Set the Step Number and Step Length according to the sample focal depth 

as well as the objective power.  

3. Click the Test Run button, and a test run will launch for one to examine 
if the Step Number and Step Length are proper.  

4. After the Test Run, the system will return to its original position 

automatically. If the Step Number and Step Length are satisfactory, click the 

Start button to do the Image Fusion; otherwise, re-set the Step Number and 

Step Length (step 2) in Image Fusion Procedure.  

2.10.15 Manual Fusion  

Manual Fusion toolbar button   

Function Prerequisites: use step motor to move the stage  

1. Make sure that the ToupView packages, step motor drivers, and UCMOS or 

UHCCD camera are correctly installed.  

2. Plug in all of the devices' cables and turn on the step motor controller 

and the microscope's light.  

Function Prerequisites: to move the stage manually  

No prerequisites.  

Image Fusion Procedure without Autofocus Controller (default)  
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Step 1. Click the Live Capture Toolbar button  and the following dialog 

will pop-up:  

  

Step 2. Use the coarse and fine focus knobs to move the sample stage up and 

down, in order to find the different positions where the clearest regions of 

the whole sample can be seen.  

Step 3. Click the Capture button to capture an image into the image list 

which will be used to do the fusion.  

Step 4. Unless there is more than one image being captured, the Fusion and 

Clear buttons will not be enabled.  

Step 5. If enough images are captured, click the Fusion button to do the 

image fusion. If the captured images are not satisfactory, one can click the 

Clear button to clear the captured images, and capture new images.  

Step 6. If Fusion is clicked, please wait for some time to get the fusion 
result.  

Manual Fusion Key Points for Reference   

1. Use the coarse and fine focus knobs to move the sample stage up and down.  

2. Clicking the Capture button will capture the current image into the image 
fusion list.  

3. Repeat steps 1-3 until there are enough images.  

4. Click the Fusion button will start image fusion. Wait for some time and a 
fantastic fusion result will be displayed in a new window.  

2.10.16 Measure  
If one wish to perform the measure in units other than Pixels, the 

corresponding Software Power must be defined (if not defined) or chosen (if 

defined). See the Live Capture Toolbar: Define Software Power button for 

details.  

Step 1. If the used microscope's objective is 40X, then adjust Software Power 

from the Software Power combo box  to 40X.   
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Step 2. Click the Measure button  and select Length Measurement from the 

drop-down menu as shown below:  

  

There should be a big and a small alignment cursor as shown below (one can 

set their properties in the Measurement Setting••• menu shown above).  

Step 3. Click the Start Point, move the mouse, and click the End Point.  

  

After the mouse button is released, a dialog listing the measurement results 

will automatically pop-up as shown below:  

  

Step 4. The Angle Measurement is the same as the Length measurement, but need 

to click three points.  

Step 5. One can also perform Batch Measurement on the Live Capture window. 

The Batch Measurement menu is shown below, it includes Length Measurement, 

Angle Measurement and View Result•••.  
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Take Length Measurement for example  

a).Choose the Batch Measurement->Length Measurement  

b).Click the Start Point, move the mouse, and click the second point (End 
Point).  

  

After the mouse button is released, the first Length Measurement is finished  

c).Repeat a) and b) again will end another Length Measurement.  

…  

d)Choose Batch Measurement->View Results•••, a dialog called Measurement 

Result shown below:  

 Click 

Process>, 3 submenus will be shown as   
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Export to Excel  

Choose this menu will export the Batch Measurement to an Excel sheet.  

  

Export to Text•••  

Choose this menu will export the Batch Measurement to a Text file.  

Average•••  

Choose this menu will give the average result of the Batch Measurement as 
below  

  
2.10.17 ROI (Region of Interest)  

Toolbar Icon:  ROI means region of interest. This utility function is 

used to help focus on the region of interest by shrinking the Live Capture 

window to the defined ROI size. Click this icon will pop-up a menu as below:  

  

ROI by Rectangle：Choose this menu, the mouse cursor will become a blue cross. 

Click on the Start Point of ROI, and then move the mouse cursor to the End 

Point of ROI as below:  
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Click the mouse again, the Live Capture window will shrink to the selected 

ROI as below:  

  

ROI by Dialog••• Choose this menu, a dialog will pop-up as below:  

  

In this dialog, the shrink ratio and the coordinates of the start point (upper 

left point) of the ROI can be manually input to help to define the ROI 

precisely.  

ROI Clear: Choose this menu will clear all previously defined ROI and reset 

the Live Capture window to its original size.   
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2.11 Live Capture Statusbar  

  

1. The camera name.  

2. The Software Power and its resolution.  

3. The current horizontal or vertical ruler’s length between two numbers in 
the Live Capture window.  

Double click this icon will invoke a Process Frame: Options->Annotation••• -

>Length tab and one can check the Unit or define the new Unit.  

Click this icon with the right mouse button will pop-up the Unit Context 

Menu. Here, the different Unit can be selected with ease. One can also 

Customize the Unit by choose Customize•••menu, this will be the same as the 

double clicks operation.  
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4. ROI: Region of interest. 100% means the whole video is displayed. See Live 
Capture Frame: Live Capture Toolbar->ROI for details.  

5. Marker’s position and Water Marker position and rotations.   

See Process Frame: Acquire->Video Marker•••,   

     Acquire->Video Watermark•••,   

     Live Capture Frame: Live Capture Toolbar-> Arrow key to move marker or 

watermark,   

     Live Capture Frame: Live Capture Toolbar->Arrow key to rotate watermark 

for details.   
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3 Browser Frame  

3.1 Browser Frame Introduction  
With ToupView’s Browser Frame, files and images can be browsed, sorted, 

managed, manipulated, and shared. Different tools and panes can be combined 

to perform sophisticated searching and filtering operations, and view 

thumbnail previews of the images.   

The Browser Frame is fully customizable. It can be moved, resized, hidden, 

docked, or closed. One can also stack the panes together for easy reference 

and accessibility, and to maximize screen space.  

  

ToupView’s Browser Frame consists of the following panes:  

1. Browser Frame Menu.  
2. Start Frame Toolbar: See Start Frame: Start Frame Toolbar.  
3. Browse Frame Toolbar: See Browser Frame: Browser Frame Toolbar.  
4. Folder: This pane displays the computer directory structure, much like the 

directory tree in Windows Explorer. One can use the Folder pane to browse 

through the folders and display their contents in the File List pane. One 

can also display the contents of multiple folders in the File List Pane by 
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clicking the Easy Select box opposite each folder on the left side of the 

pane.  

5. File List Pane: File List Pane: This pane displays the images in the 
selected folder. The File List Pane is always visible, and cannot be hidden 

or closed. One can customize the File List Pane by changing either the way 

the files are displayed or the size of the thumbnails.   
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3.2 File  

3.2.1Open Image•••   Ctrl+O  
See Process Frame: File->Open Image•••  

3.2.2 Open Video•••  
See Process Frame: File->Open Video•••.  

3.2.3 Paste as New File•••  
See Process Frame: File->Paste as New File•••.  

3.2.4 Print Setup•••  
See Process Frame: File->Print Setup•••.  

3.2.5 Recent File  
See Process Frame: File->Recent File.  

3.2.6 Exit  
See Process Frame: File->Exit.   
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3.3 Acquire  

3.3.1 Live Capture 
See Process Frame: Acquire->Live Capture.  

3.3.2 Software Power  
See Process Frame: Acquire->Software Power.  

3.3.3 Manage Software Power•••  Ctrl+M  
See Process Frame: Acquire->Manage Software Power•••.  

3.3.4 Video Marker•••  
See Process Frame: Acquire->Video Marker•••.  

3.3.5 Video Overlay Text•••   Ctrl+D  
See Process Frame: Acquire->Video Overlay Text•••.  

3.3.6 Video Watermark•••    Ctrl+W  
See Process Frame: Acquire->Video Watermark•••.  

3.3.7 Auto Maximum Size•••  Ctrl+U  
See Process Frame: Acquire->Auto Maximum Size•••.  

3.3.8 Capture with Marker and Watermark   Ctrl+F  
See Process Frame: Acquire->Capture with Marker and Watermark.  

3.3.9 Twain:Select Device•••  
See Process Frame: Acquire->Twain:Select Device•••.  

3.3.10 Twain:Acquire•••  
See Process Frame: Acquire->Twain:Acquire•••.  

  

3.4 Edit  

3.4.1Cut   Ctrl+X  

Toolbar button . One can Cut files and Paste them into another folder in 
the  

Browser's File List Pane using ToupView. To Cut files, do the following:  

Select one or more files and choose Edit ->Cut (shortcut: Ctrl+X).  
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3.4.2 Copy   Ctrl+C  
One can Copy files and Paste them into another folder using ToupView. To Copy 

files:  

In the Browser's File List Pane, select one or more files and choose Edit-

>Copy or click  (shortcut: Ctrl+C).  

3.4.3 Paste   Ctrl+V  

After copying or cutting file(s), one can Paste  them into a folder using 

ToupView. To Paste a file(s) in ToupView:  

Select the file(s) in the Browser's File List Pane and navigate to the proper 

folder in the Folders pane. Then select Edit->Paste (shortcut: Ctrl+V).  

3.4.4 Paste Shortcut  
After copying or cutting files, one can Paste Shortcut into a folder using 
ToupView.  

To Paste the Shortcut of a file in ToupView:  

Select the file(s) in the Browser's File List Pane and navigate to the proper 

folder in the Folders pane. Then select Edit->Paste Shortcut.  

3.4.5 Select All   Ctrl+A  
When organizing files and folders, one can select all of the files.  

To Select All files in the current directory, click Edit->Select All 
(shortcut:  

Ctrl+A).  

3.4.6 Inverse Selection  
When organizing files, one can invert a selection in order to select all of 

the files that were not previously selected.   

To perform this operation, click Edit->Invert Selection.  

3.4.7 Delete File   Delete  

Delete File toolbar button . One can also Delete one or more files or 

folders from the Browser Window. To remove a file or folder from the Browser 

Window:  

Select one or more files or folders.   

Choose Edit->Delete File or click  (shortcut: Delete button). A Confirm 
File  

Delete dialog will pop-up. In the Confirm File Delete dialog, click Yes to 

move the file to the desktop recycle bin, or click No to cancel.  
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3.4.8 Pause   Pause  

Pause toolbar button . When Browser is shown or when the directory in the  

Folders is changed, ToupView will automatically begin to cache image 

thumbnails in the database. When thumbnails are cached, they are recalled 

from the database instead of generated from the file each time start ToupView 

and choose the Browser menu. This can improve system performance.  

Click this button  and ToupView will Pause caching image thumbnails in the 

File List Pane.  

Click this button again to continue caching image thumbnails in the File List 

Pane.   
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3.5 View  

3.5.1File Bar  
The Folders Pane includes a folder tree of all of the folders in the computer, 

similar to Windows Explorer. One can view the contents of the folders in the 

File List Pane on the right side of the Browser interface.  

One can add, delete, or rename files and folders in the Folders Pane. One can 

also drag files and folders to new locations in the pane.  

To show/hide the File Bar : Check View->File Bar or click  icon on the  

Browser Frame Toolbar.  

3.5.2 Tool Box   Ctrl+T See 

Process Frame: View->Tool Box  

3.5.3 Annotation Manager  
See Process Frame: View->Annotation Manager  

3.5.4 Sort  

Sort toolbar button . In the Browser window, one can sort files according 

to different file properties in order to quickly organize images, find 

specific files, and create a range of files with similar attributes for easy 

selection.  

To Sort items in the File List:  

3.5.4.1 Sort->Sort by Names  

Sort the image files in order of names.  

3.5.4.2 Sort->Sort by Type  

Sort the image files in order of type.  

3.5.4.3 Sort->Sort by Size   

Sort the image files in order of size.  

3.5.4.4 Sort->Sort by Width  

Sort the image files in order of width.  

3.5.4.5 Sort->Sort by Height  

Sort the image files in order of height.  

3.5.4.6 Sort->Forward  

Sort the image files in order of the Forward mode (i.e. 1,2,3,4).  

3.5.4.7 Sort->Reverse  
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Sort the image files in order of the Reverse mode (i.e. 4,3,2,1).  

The Sort settings are saved until they are changed. For example, if one sort 

images in the File List Pane according to the Type, the images will remain 

sorted according to Type until the Sort settings are changed.  

3.5.5 Icons  

Icons toolbar button . One can select different view modes in the File 
List  

Pane. The Thumbnail view mode displays small images previews.  

Then select one of the following:  

3.5.5.1 Icon->Large Icons  

Show the image files in Large Icon format.  

3.5.5.2 Icon->Small Icons  

Show the image files in Small Icon format.  

3.5.6 Refresh  

Refresh toolbar button:  If the files in the Folders are altered outside 
of  

ToupView, after switch back to ToupView, one can Refresh the image files in 

the current directory to update the Thumbnails.  

Press  (shortcut: F5) on the Browser Frame Toolbar to Refresh the image 
files.  
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3.6 Options  

3.6.1Preference•••  Shift+P  
See Process Frame: Options->Preference•••.  

3.6.2 Annotation•••  
See Process Frame: Options->Annotation•••.  

3.6.3 Auto Correction•••  
See Process Frame: Options->Auto Correction•••.   
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3.7 Window  

3.7.1Cascade  
See Process Frame: Window->Cascade.  

3.7.2 Tile  
See Process Frame: Window->Tile.  

3.7.3 Arrange Icons  
See Process Frame: Window->Arrange Icons.   
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3.8 Help  

3.8.1Help Contents  F1  
See Process Frame: Help->Help Contents.  

3.8.2 Show Start Page  
See Process Frame: Help->Show Start Page.  

3.8.3 Check to Update  
See Process Frame: Help->Check to Update.  

3.8.4 About••• See Process 

Frame: Help->About.  
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3.9 Browser Frame Toolbar  

ToupView’s Browser Frame Toolbar is shown below. To invoke the Browser, choose 

View->Browser (shortcut Ctrl+B).  

  

Each icon's function is described below:  

1. File Bar: Show/Hide the Browser Folders. See Browser Frame: View->File 
Bar for details.  

2. Delete File: Send the selected file(s) to the Recycle Bin. See Browser 
Frame: Edit->Delete File for details.  

3. Refresh: Reload images. See Browser Frame: View->Refresh for details.  
4. Icons: Select thumbnail mode. See Browser Frame: View->Icons for 

details. 5. Sort: Arrange images by name, type, size, width, height, 

or by alphabetical order. See Browser Frame: View->Sort for details. 

6. Pause: Pause loading the images from the current directory. . See 

Browser Frame: Edit->Pause for details.  

7. Property: Display the selected image properties. When a file is 

selected, this button will be enable.Click it will pop-up XXX Properties 

dialog as below. Here, XXX is the selected file name.  
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3.10 Browser Frame Statusbar  

3.10.1 Selection No  
When no file is selected in the File List Pane in the current directory, the 

Statusbar will display the information about the selected file location and 

the whole image files in the current directory as shown below:  

  

3.10.2 Single Selection   
When a single file is selected in the File List Pane in the current directory, 

the Statusbar will display the selected file information as shown below:  
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1. The selected file location in number and the total file number listed in 
the current selected directory, here, they are 8 and 58 respectively.  

2. The selected file name.  

3. The selected file color bits and its width and height.  

Drag the selected file out of thr Browser will open it in a Image window  

3.10.3 Multiple Selections   
When multiple files are selected in the File List Pane in the current 

directory, the Statusbar will display the information of the multiple selected 

file properties as shown below:   

  

1. The number of selected files and the total number of files in the 

current directory.  

2. If the selected files' color bits and dimensions are the same, they 

will be displayed; otherwise, nothing will be displayed.  

Use   
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4 Start Frame  

4.1 Start Frame Introduction  
The Start Frame includes:   

1. Start Frame Menu.   

2. Start Frame Toolbar: See Start Frame: Start Frame Toolbar.  

3. Start Page: Here, the user can launch the:  

Open Image File: Click on the Recent Files list can open it in an Image 

Window. See Process Frame: File->Recent Files, Options->Preference->Misc-> 

Privacy for more information.  

Browser Frame: Click on the Browser Folder to browse the images in the 

selected directory.  

Live Capture: Click on the Camera name to start the Live Capture very quickly.  

See Process Frame: Help->Show Start Page for details.  

  



ToupView Help  

  

  
  

188  

4.2 File  

4.2.1Open Image•••   Ctrl+O  
See Process Frame: File->Open Image•••.  

4.2.2 Open Video•••  
See Process Frame: File->Open Video•••.  

4.2.3 Paste as New File•••  
See Process Frame: File->Paste as New File•••.  

4.2.4 Print Setup•••  
See Process Frame: File->Print Setup•••.  

4.2.5 Recent File  
See Process Frame: File->Recent File.  

4.2.6 Exit  
See Process Frame: File->Exit.   
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4.3 Acquire  

4.3.1Live Capture 
See Process Frame: Acquire->Live Capture.  

4.3.2 Software Power  
See Process Frame: Acquire->Software Power.  

4.3.3 Manage Software Power•••  Ctrl+M  
See Process Frame: Acquire->Manage Software Power•••.  

4.3.4 Video Marker•••  
See Process Frame: Acquire->Video Marker•••.  

4.3.5 Video Overlay Text•••  Ctrl+D  
See Process Frame: Acquire->Video Overlay Text•••.  

4.3.6 Video Watermark•••  Ctrl+W  
See Process Frame: Acquire->Video Watermark•••.  

4.3.7 Auto Maximum Size•••  Ctrl+U  
See Process Frame: Acquire->Auto Maximum Size•••.  

4.3.8 Capture with Marker and Watermark   Ctrl+F  
See Process Frame: Acquire->Capture with Marker and Watermark.  



ToupView Help  

  

  
  

190  

4.3.9 Twain:Select Device•••  
See Process Frame: Acquire->Twain:Select Device•••.  

4.3.10 Twain:Acquire•••  
See Process Frame: Acquire->Twain:Acquire•••.  

4.4 View  

4.4.1Browser   Ctrl+B  
See Process Frame: View->Browser.  

4.4.2 Tool Box   Ctrl+T  
See Process Frame: View->Tool Box.  

4.4.3 Annotation Manager See Process 

Frame: View->Annotation Manager.   
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4.5 Options  

4.5.1Preference•••  Shift+P  
See Process Frame: Options->Preference•••.  

4.5.2 Annotation•••  
See Process Frame: Options->Annotation•••.  

4.5.3 Auto Correction•••  
See Process Frame: Options->Auto Correction•••.   
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4.6 Window  

4.6.1Cascade  
See Process Frame: Window->Cascade  

4.6.2 Tile  
See Process Frame: Window->Tile  

4.6.3 Arrange Icons  
See Process Frame: Window->Arrange Icons   
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4.7 Help  

4.7.1Help Contents   F1  
See Process Frame: Help->Help Contents  

4.7.2 Show Start Page  
See Process Frame: Help->Show Start Page  

4.7.3 Check to Update  
See Process Frame: Help->Check to Update  

4.7.4 About•••  
See Process Frame: Help->About  
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4.8 Start Frame Toolbar  

  

1. Open: Open an image file. See Process Frame: File->Open Image•••.  

2. Save: Save image file. See Process Frame: File->Save.  

3. Cut: Cut the selected Annotation objects. See Process Frame: Edit->Cut.  

4. Copy: Copy the selected Annotation objects or rectangular area image to 

clipboard. See Process Frame: Edit->Copy.  

5. Paste: Paste the Annotation objects above the Background layer. See 

Process Frame: Edit->Paste.  

6. Browser: Show/Hide Browser window, see Process Frame: View->Browser for 

details.  

7. Tool Box: Show/Hide Tool Box. See Process Frame: Edit->Tool Box.  

8. Live Capture: Start Live Capture. See Process Frame: Acquire->Live 
Capture.  

9. Twain:Select Device: See Acquire->Twain: Select Device•••.  

10. Twain:Acquire: See Process Frame: Acquire->Twain: Acquire•••.  
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